Contenu | Rechercher | Menus
Selon les tags présents sur cette page, les informations qu'elle contient n'ont pas été vérifiées depuis Ubuntu 10.04 LTS.
Cette page est considée comme vétuste et ne contient plus d'informations utiles.
Apportez votre aide…

FIXME : Il faudrait clarifier la page, en supprimant les trop vieilles versions d'Ubuntu, et en simplifiant le tout (éviter les nombreuses répétitions). De plus, je ne sais pas si la diviser la page avec les différentes version d'Ubuntu est judicieux car la procédure me semble être la même partout. Je pense qu'il faudra aussi mettre la page aux normes syntaxique du wiki.

Imprimante Lexmark Z600 série

Cette page propose une méthode utilisant l'outil de configuration d'imprimante sur Ubuntu 12.04 pour installer le pilote de l'imprimante Lexmark Z600. Deux autres méthodes (qui n'ont semble-t-il pas été vérifiées récemment) sont également proposées : une par paquet debian et l'autre à travers l'utilisation d'alien.
Vous trouverez une liste des modèles pour lesquels ce pilote est également valable ici.

Le paquet z60r U0cups pour Hardy 8.04 semble buggé. La solution consiste à créer un lien symbolique de /etc/init.d/cups pointant vers /etc/init.d/cupsys :

ln -s /etc/init.d/cupsys /etc/init.d/cups

FIXME Cette solution est-elle toujours viable sur les versions récentes ?.
Si vous êtes confronté à un problème suite à l'installation des paquets générés par alien reportez-vous à ce sujet du forum.

Installation via l'outil de configuration des imprimantes sur Ubuntu 12.04 (precise)

Suivez la procédure d'utilisation de l'outil de configuration des imprimantes. A l'étape de choix de pilote, choisissez :

Manufacturer-supplied PPD files for Lexmark's PostScript printers

Au terme de cette procédure l'imprimante et prête à être utilisée.

Si cette procédure ne fonctionne pas, vous pouvez tenter :

1-installer libstdc++5

sudo apt-get install libstdc++5

2-installer getlibs-all.deb

3- installer lexmark.z600-0.4.deb

et suivez la procédure d'installation classique en sélectionnant LEXMARK/z600 (tout en bas) : l'outil de configuration des imprimantes

Il semble que des utilisateurs ont des soucis d'installation dus a une dépendance non satisfaite (libcupsys2), qui est probablement devenue libcups2 (sans certitude). Si certains peuvent confirmer…..

Installation par paquet Debian

  1. Téléchargez les 2 fichiers .deb suivants :
  2. Installez les paquets .deb depuis le dossier où vous les avez téléchargé.

FIXME Sur 64 bits ça marche avec ça ?
Cette méthode fonctionne jusqu'à la 11.10 en installant manuellement et en ligne de commande les paquets.

Installation par la méthode Alien

Les 2 méthodes données ici sont très proches. Si celle pour Hardy fonctionne sur Lucid merci de l'indiquer.

Pré-réquis

Préparation

Depuis un terminal saisissez les commandes suivantes:

  1. Se placer dans le dossier où vous avez téléchargé l'archive :
    cd chemin/vers/dossier/contenant/l'archive

    exemple si vous l'avez placé sur le bureau tapez

    cd ~/Bureau
  2. Extraire l'archive téléchargée:
    tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz
  3. Génération d'une nouvelle archive à partir des lignes nécessaires extraites précédemment (sinon le script sera défaillant) :
    tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz
  4. Extraction de cette nouvelle archive :
    tar -xvzf install.tar.gz

Installation sur Ubuntu 10.04 (Lucid Lynx)

  1. Conversion des paquets .rpm en archive .tgz via alien :
    sudo alien -t z600cups-1.0-1.i386.rpm
    sudo alien -t z600llpddk-2.0-1.i386.rpm
  2. Extraction des archives.tgz dans le dossier racine / :
    sudo tar xvzf  z600llpddk-2.0.tgz -C /
    sudo tar xvzf z600cups-1.0.tgz -C /

    FIXME Pas possible direct en .deb comme pour hardy?

  3. Mise à jour des bibliothèques
    sudo ldconfig
  4. Se placer dans le dossier /usr/share/cups/model :
    cd /usr/share/cups/model
  5. Extraction de l'archive pour obtenir un .ppd :
    sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz 

Testé sur Lexmark x1270 - imprimante & scanner

Installation sur Ubuntu 8.04 (Hardy Heron)

FIXME Si cette méthode fonctionne sur Lucid merci de l'indiquer.

  1. Conversion des paquets .rpm en paquets .deb :
    sudo alien --scripts z600cups-1.0-1.i386.rpm
    sudo alien --scripts z600llpddk-2.0-1.i386.rpm
  2. Installez les paquets fraichement créés:
    sudo dpkg -i z600cups_1.0-2_i386.deb
    sudo dpkg -i z600llpddk_2.0-2_i386.deb

Si vous avez un problème à l'installation des paquets reportez vous à la note en tête de cette page

Finalisation de l'installation

Relancez le démon CUPS.

Sur Lucid

Dans un terminal saisissez:

sudo service cups restart

Sur Hardy

Dans un terminal saisissez:

sudo /etc/init.d/cupsys force-reload

FIXME sudo invoke-rc.d cupsys force-reload ne marche pas ?

Vérification de la bibliothèque

Avant de tester l'impression il vous faut vérifier que votre système a les bibliothèques nécessaires en saisissant dans un terminal:

/usr/lib/cups/backend/z600
  • Si vous avez ce message d'erreur :
     error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

    Il vous manque la librairie libstdc++5 que vous pouvez télécharger ici.
    Installez ensuite ce paquet depuis le dossier où vous l'avez téléchargé.
    Ce paquet étant en 32bits, pour l'installer sur un environnement 64 bits appuyez vous sur cette page. Si cette méthode ne fonctionne pas, essayez alors celle-ci donnée sur le forum (n'hésitez pas à lire les explications).

  • Si aucune erreur ne vous est retournée, c'est que votre imprimante est prête à fonctionner.

Le pilote z600 devrait désormais apparaître dans la liste des pilotes. FIXME Dans Système –>Administration –> Impression?

Sous 10.10, pas de message d'erreur mais le paquet libstdc++5 est tout de même indispensable au bon fonctionnement

Les deux versions de libstdc++ peuvent tout à fait cohabiter.

Voir Aussi

  • Informations pour Lucid tirées de ce tutoriel (en) très détaillé.</note>
  • Problème de paquet cassé suite à l'usage d' alien sur 8.04 dans ce sujet du forum.FIXME Voir si c'est à laisser.

Imprimantes compatibles

Liste des imprimantes compatibles avec le driver Z600

Lexmark Z601
Lexmark Z602
Lexmark Z603
Lexmark Z604
Lexmark Z605
Lexmark Z611
Lexmark Z612
Lexmark Z613
Lexmark Z614
Lexmark Z615
Lexmark Z617

Également compatible avec: (pas indiqué sur le site de Lexmark)

Lexmark Z515
Lexmark Z517
Lexmark Z640
Lexmark Z705 (parfois problèmes de marges)
Lexmark 1100
Lexmark X1150
Lexmark X1190
Lexmark X1170
Lexmark X1180
Lexmark X1250
Lexmark X1270
Lexmark X1290
Dell photo printer 720
Dell A920   

Contributeurs :Portix, Ju,Ced-Ryk, remise en forme fabux

1) Il vous faudra entrer le captcha en bas de la page. Attention celui-ci est sensible à la casse ! Ensuite cliquez sur le bouton juste en dessous.

imprimante_lexmark_z600.txt · Dernière modification: Le 30/11/2012, 13:02 par YoBoY
Le contenu de ce wiki est sous licence : CC BY-SA v3.0