Contenu | Rechercher | Menus

Connexion à une base de donnée Mysql sous LibreOffice

Cette page présente la mise en place d'une connexion entre une base MySQL et LibreOffice.

Introduction

Description des logiciels utilisés :

  • Mysql est un serveur de bases de données relationnelles SQL.
  • ODBC : format de Microsoft permettant la communication entre des clients et la plupart des SGBD.
  • LibreOffice, le logiciel libre de bureautique de référence.

Vous pouvez vous connectez avec Base de trois manières:

Avec l'extension libreoffice-mysql-connector

Installez le paquet libreoffice-mysql-connector qui est une extension de connexion MariaDB/MySQL pour LibreOffice. Si vous avez des problèmes avec ce pilote sous Ubuntu 16.04 voir ici. Comme indiqué en ce lieu le JDBC fonctionne.

Avec un pilote JDBC

Installez le paquet libha-jdbc-java. Dans Libreoffice, avant de pouvoir utiliser un pilote JDBC, vous devez ajouter son chemin de classe. Choisissez Outils → Options → LibreOffice → Avancé, et cliquez sur le bouton Chemin de classe. Naviguez jusqu'à l'archive qui se trouve dans /usr/share/java/mysql-connector-java-5.1.28.jar. Après avoir ajouté les informations de chemin, redémarrez LibreOffice.

LibreOffice Base s'installe avec le support du pilote JDBC comme une dépendance, paquet libreoffice-base-drivers

Le paquet libha-jdbc-java ne fournit aucun pilote JDBC mais une abstraction de haute disponibilité à toute connectivité JDBC.

Une procédure détaillée pour lire une base access avec le pilote JDBC peut se trouver ici.

Avec un pilote ODBC

À l'heure actuelle cette solution ne fonctionne pas, si quelqu'un trouve les bons paramètres, son aide est la bienvenue.

Commencez par installer les paquets libmyodbc et unixodbc-bin.

Maintenant lancez Unixodbc avec les droits d'adminstration, pour créer le pilote. Entrez la comamnde suivante dans un terminal :

gksudo ODBCManageDataSourcesQ4
  • Allez dans Advanced,
  • Pouis dans l'onglet drivers, bouton add: FIXME pour toute cette partie
name: Mysql
description: Mysql driver
driver: 
ou en 64 bits:  /usr/lib/x86_64-linux-gnu/odbc/libmyodbc.so
setup: /usr/lib/x86_64-linux-gnu/odbc/libodbcmyS.so
setup64

Laissez le reste par défaut et fermez ODBCManageDataSourcesQ4.

On va maintenant lancer ODBCManageDataSourcesQ4 en tant qu'utilisateur :

ODBCManageDataSourcesQ4

Onglet user dns, bouton add, sélectionnez le pilote nommé Mysql, puis cliquez sur le bouton OK

name: nom_de_la_base
server: localhost
database: nom_de_la_base

Laissez le reste par défaut et fermez ODBCManageDataSourcesQ4.

Connection à la base de donnée

Dans LibreOffice :

  • Onglet Fichier → Nouveau → Base de données,
  • Cochez la case Se connecter à une base de données existante, puis sélectionnez Mysql dans la liste au-dessous,
  • Cliquez sur le bouton Suivant,
  • Si vous avez installé:
    • L'extension, choisissez Connecter directement,
    • Si vous avez activé le pilote ODBC choisissez Connection utilisant ODBC,
    • Si vous avez activé le pilote JDBC choisissez Connection utilisant JDBC,
  • Cliquez sur le bouton Suivant
  • Dans le cas d'une connexion directe et JDBC remplissez les champs comme suit:
    • Nom de la base de données, entrez le nom de votre base de donnée;
    • "Serveur", entrez localhost, si la base se trouve sur votre pc, ou l'adresse IP d'un autre serveur,
  • Cliquez sur le bouton Suivant,
  • Tapez le nom d'utilisateur que vous utilisez pour accéder à votre base, et suivant la configuration de votre serveur MySQL, cochez ou non Password required,
  • Cliquez sur le bouton Terminer.

Ça y est, vous avez maintenant accès à votre base MySQL sous LibreOffice.

Notes

  • Pour accéder rapidement aux bases de données, tapez sur la touche F4 sous LibreOffice.
  • Pour supprimer une base de données sous LibreOffice : onglet outils/options → LibreOffice Base → base de données

Voir aussi


Contributeurs : Yeffries, L'Africain, Poupoul2



Le contenu de ce wiki est sous licence : CC BY-SA v3.0