Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
musescore [Le 12/09/2010, 10:44]
Gemnoc Mise en forme.
musescore [Le 18/05/2017, 13:35] (Version actuelle)
Baptclub [Problème connu] [[apt>gawk]]** → **[[apt>gawk]]**.
Ligne 1: Ligne 1:
-{{tag>hardy jaunty lucid audio mao midi}}+{{tag>Xenial ​audio mao midi}}
 ---- ----
 +{{ :​applications:​mscore.png?​70}}
 +====== MuseScore : édition de partitions musicales ======
  
 +**MuseScore** est un logiciel d'​édition de partitions musicales. Il utilise QT4, et les ressources [[:midi]] de votre carte son.\\
 +**MuseScore**: ​
 +  * est compatible ALSA;
 +  * possède un synthétiseur intégré;
 +  * supporte l'​import/​export du MIDI, et du musicXML;
 +  * peut exporter graphiquement les partitions en PDF, SVG, PNG.
  
- +{{ :applications:​mscore_xenial.png?450 }}
-====== MuseScore ​édition de partitions musicales ======= +
- +
-**MuseScore** est un logiciel d'​édition de partitions musicales. Utilise QT4, et les ressources midi de votre carte son. Compatible ALSA. Il possède aussi un synthétiseur intégré. Il supporte l'​import export du MIDI, et du musicXML. Il peut exporter graphiquement les partitions en PDF, SVG, PNG. +
 ===== Pré-requis ===== ===== Pré-requis =====
  
   * Disposer des [[:​sudo|droits d'​administration]].   * Disposer des [[:​sudo|droits d'​administration]].
   * Disposer d'une connexion à Internet configurée et activée.   * Disposer d'une connexion à Internet configurée et activée.
-  * Avoir activé l'​accès au [[:​depots#​depots_officiels|dépôt Universe]]. 
  
 ===== Installation ===== ===== Installation =====
  
-==== Depuis les dépôts =====+Il suffit d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​musescore]]**.
  
-Il suffit d'​[[:​tutoriel:​comment_installer_un_paquet|installer ​le paquet]] **[[apt://​mscore|mscore]]**.+==== Depuis ​le PPA ====
  
-Si vous utilisez souvent MuseScore, il est préférable d'​installer la dernière version stable depuis le [[PPA]]. 
- 
-==== Dernière version stable ​ ==== 
- 
-On trouve sur le dépôt PPA du projet des paquets Ubuntu pour la version stable 0.9.6. Ces paquets récents donnent une installation où l'on peut choisir la langue de travail, en particulier le français. 
- 
-=== Ubuntu 9.10 et suivants === 
   * [[:​PPA|Ajoutez le PPA]] **ppa:​mscore-ubuntu/​mscore-stable**((https://​launchpad.net/​~mscore-ubuntu/​+archive/​mscore-stable)) dans vos sources de logiciels.   * [[:​PPA|Ajoutez le PPA]] **ppa:​mscore-ubuntu/​mscore-stable**((https://​launchpad.net/​~mscore-ubuntu/​+archive/​mscore-stable)) dans vos sources de logiciels.
   * [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|Rechargez la liste des paquets]].   * [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|Rechargez la liste des paquets]].
-  * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt://musescore|musescore]]**.+  * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>musescore|musescore]]**.
  
-=== Ubuntu 9.04 et précédents === 
-  * [[:​PPA|Ajoutez le PPA]] suivant dans vos sources de logiciels :<​file>​deb http://​ppa.launchpad.net/​mscore-ubuntu/​mscore-stable/​ubuntu VOTRE_VERSION_ICI main  
-deb-src http://​ppa.launchpad.net/​mscore-ubuntu/​mscore-stable/​ubuntu VOTRE_VERSION_ICI main</​file>​En prenant soin de remplacer « VOTRE_VERSION_ICI » par votre version d'​Ubuntu,​ soit : hardy ou jaunty. 
-  * [[:​tutoriel:​comment_installer_un_paquet|Installer les paquets]] suivants : **[[apt://​fluid-soundfont-gs,​fluid-soundfont-gm,​libqt4-designer|fluid-soundfont-gs,​ fluid-soundfont-gm,​ 
-libqt4-designer]]** 
-  * Puis seulement **[[apt://​mscore,​mscore-common|mscore et mscore-common]]**. 
  
-<note tip>Sous Ubuntu 9.04, le lancement de MuseScore avorte. Cela se corrige en [[:​tutoriel:​comment_modifier_un_fichier|éditant le fichier]] de démarrage **/​etc/​modules** pour lui ajouter la ligne suivante :<​file>​snd_seq</​file>​ +<note important>​Il est conseillé de supprimer (ou désactiver) les dépôts ​[[:​PPA]] ​ajoutés à vos sources de logiciels après installation ​du paquet souhaité ​pour éviter des mises à jour des autres paquets du PPA.</​note>​
- +
-Cette adjonction semble aussi bénéfique pour le fonctionnement de jack.</​note>​ +
- +
-<note important>​Il est conseillé de supprimer (ou désactiver) les dépôts ajoutés à vos sources de logiciels après installation pour éviter des mises à jour des autres paquets du PPA.</​note+
- +
- +
- +
-==== Pré-version (instable) ==== +
- +
-Ici, ce sont des paquets extrêmement récents. Tout juste sortie du SVN. A réserver aux testeurs ou utilisateurs avertis. +
- +
-Suivez les mêmes instructions que pour la [[#​dernière version stable]], mais en lui substituant ce dépôt PPA : +
- +
-=== Ubuntu 9.10 et suivant === +
- +
-**ppa:​mscore-ubuntu/​ppa**((https://​launchpad.net/​~mscore-ubuntu/​+archive/​ppa)) +
- +
-=== Ubuntu 9.04 et précédents === +
- +
-<​file>​deb http://​ppa.launchpad.net/​mscore-ubuntu/​ppa/​ubuntu VOTRE_VERSION_ICI main  +
-deb-src http://​ppa.launchpad.net/​mscore-ubuntu/​ppa/​ubuntu VOTRE_VERSION_ICI main</​file>​ +
- +
-==== À partir des sources ==== +
-Pour Ubuntu 8.04+ +
- +
-=== Pré-requis pour la compilation === +
- +
-Il est nécessaire : +
-  *d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​libqt4-dev|libqt4-dev]]** +
-  *d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​cmake|cmake]]** +
-  *d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​libasound2-dev|libasound2-dev]]** +
-  *d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​alsa|alsa]]** +
-  *d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​g++|g++]]**  +
-  *d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​libsndfile1-dev|libsndfile1-dev]]** +
-  *d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​make|make]]** +
-  *d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​portaudio19-dev|portaudio19-dev]]** +
- +
-=== Téléchargement et décompression des sources === +
-  * Téléchargement des sources +
-    <​code>​ +
-      wget http://​downloads.sourceforge.net/​mscore/​mscore-0.9.6.tar.bz2</​code>​ +
-  * on les décompresse +
-    <​code>​ +
-      bunzip2 mscore-0.9.6.tar.bz2 +
-      tar xf mscore-0.9.6.tar</​code>​ +
-  * On lance la compilation (un peu long...) +
-     <​code>​ +
-       cd mscore-0.9.6 +
-       ​make</​code>​ +
-  * Enfin, installation du programme :  +
-    <​code>​ +
-       sudo make install</​code>​ +
-  * Et on efface nos traces ​  +
-    <​code>​ +
-      make clean</​code>+
  
 ===== Utilisation===== ===== Utilisation=====
  
-Lancez l'​application ​depuis ​le menu //​Applications -> Son et Vidéo -> MuseScore// ​ou //via// la [[:​commande_shell|commande]] suivante :+Lancez l'​application ​via le [[:​unity#​tableau_de_bord_dash|tableau de bord]] (Unity) ​ou via le [[:​terminal]] (toutes versions d'​Ubuntu) avec la [[:​commande_shell|commande]] suivante : ​<​code>​mscore</​code>​
  
-  mscore 
  
 +=====Problème connu=====
 +Il semblerait que le problème ci-dessous ne soit lié ni à ALSA ni à padsp… mais à l'​absence du paquet gawk lors de l'​installation de MuseScore. À confirmer.
 +Il peut arriver qu'au lancement de MuseScore celui-ci monopolise le pilote ALSA, plus aucun son n'est alors audible.\\
 +Une solution qui a été trouvée pour Ubuntu [[:​Precise|12.04]] est d'​[[:​tutoriel:​comment_modifier_un_fichier|éditer avec les droits d'​administration]] le fichier **/​usr/​share/​applications/​mscore.desktop** pour remplacer la ligne 
 +<​file>​Exec=mscore</​file>​
 +par
 +<​file>​Exec=padsp mscore</​file>​
 +Pour l'​explication,​ il est probable que MuseScore fonctionne avec OSS. La commande ''​padsp''​ permet ainsi de rediriger le flux oss vers PulseAudio, qui gère le multiflux.
  
-Ou alors, ​à l'aide du lanceur d'​application : [Alt] + [F2] =taper **mscore** +Il semblerait que le problème ci-dessus ne soit lié ni à ALSA ni à padsp… mais à l'absence ​du paquet **[[apt>gawk]]** lors de l'​installation de MuseScore. À confirmer.
  
 ===== Désinstallation ===== ===== Désinstallation =====
 Dans le cas d'une installation par les dépôts officiels ou les PPA, [[:​tutoriel:​comment_supprimer_un_paquet|supprimer le paquet]] **mscore** ou **musescore**. Dans le cas d'une installation par les dépôts officiels ou les PPA, [[:​tutoriel:​comment_supprimer_un_paquet|supprimer le paquet]] **mscore** ou **musescore**.
- 
-Dans le cas, d'une installation à partir des sources, ​ 
-<​code>​xargs rm < install_manifest.txt</​code>​ 
  
 ===== Voir aussi ===== ===== Voir aussi =====
Ligne 116: Ligne 54:
   * **(fr)** [[http://​www.musescore.org/​fr/​manuel/​manuel|Le manuel de MuseScore]]   * **(fr)** [[http://​www.musescore.org/​fr/​manuel/​manuel|Le manuel de MuseScore]]
   * **(fr)** [[http://​www.musescore.org/​fr/​forum|Le Forum de MuseScore pour les bugs, fonctionnalités etc...]]   * **(fr)** [[http://​www.musescore.org/​fr/​forum|Le Forum de MuseScore pour les bugs, fonctionnalités etc...]]
-  * **(en)** [[http://​www.ubuntuforums.org/​showthread.php?​t=193848|Discussion ​« Music ​composition and midi »]] sur UbuntuForums.org+  * **(en)** [[http://​www.ubuntuforums.org/​showthread.php?​t=193848|Discussion ​« Music composition and midi »]] sur UbuntuForums.org
  
 ---- ----
- +//​Contributeurs : [[http://​forum.ubuntu-fr.org/​profile.php?​id=88806|Lasconic]],​ [[:utilisateurs:​YannUbuntu]]//​.
-//​Contributeurs : [[http://​forum.ubuntu-fr.org/​profile.php?​id=88806|Lasconic]],​ [[http://​forum.ubuntu-fr.org/​profile.php?​id=63523|YannUbuntu]]//​.+
  • musescore.1284281079.txt.gz
  • Dernière modification: Le 12/09/2010, 10:44
  • par Gemnoc