Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
shotcut [Le 18/03/2020, 19:49]
109.20.131.168 [Voir aussi]
shotcut [Le 09/10/2020, 12:06] (Version actuelle)
78.127.238.1 [Avec Snap]
Ligne 1: Ligne 1:
-{{tag>Trusty ​Xenial montage_vidéo vidéo}}+{{tag>​Xenial montage_vidéo vidéo}}
 ---- ----
- +{{ https://​www.shotcut.org/​assets/​img/​media/​shotcut-logo-512x512.png?​80}}
 ====== Shotcut ====== ====== Shotcut ======
    
Ligne 14: Ligne 14:
  
 ===== Installation ===== ===== Installation =====
-  
-==== Via un ppa ==== 
-<note warning>​Cette solution récupère une version récente en 64 bits.\\ 
-Si vous avez une version Ubuntu 32 bits, reportez-vous à l'​installation manuelle</​note>​ 
  
-Installer le pré-requis:​+==== Depuis les dépôts ====
  
-La bibliothèque libsdl2 est nécessaire pour exécuter Shotcut. +Pour installer ce logiciel, il suffit d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>shotcut|shotcut]]**. 
-<​code>​sudo ​apt install libsdl2-dev </code>+  
 +==== Avec Flatpak ====
  
-Installer le dépôt PPA: +**Articles dédiés** ​[[:flatpak]], [[:tutoriel/installer_application_flatpak|tutoriel pour l'​utiliser]].
-<​code>​sudo add-apt-repository ppa:haraldhv/​shotcut </code>+
  
-Mettre à jour et à niveau la liste d'apt et les packages: +Depuis [[https://​www.shotcut.org/​download//​|le site de Shotcut]] ou sur [[https://​flathub.org/​apps/​details/​org.shotcut.Shotcut|Flathub]],​ suivez ​les instructions qui vous concernent pour installer //Gimp// selon le [[:tutoriel/installer_application_flatpak#​niveaux_de_privileges|niveau de privilèges]] qui vous convient.
-<​code>​sudo apt-get update && sudo apt-get upgrade </code>+
  
-Installer l'​application:​ +==== Avec Snap ====
-<​code>​sudo apt install shotcut </​code>​+
  
-Une fois l'​installation terminée, lancez-le à partir de votre lanceur d'​applications ou par la commande: +**Article dédié** ​: [[:snap]].
-<​code>​shotcut </​code>​ +
-==== Via Snap ==== +
-Comme indiqué sur [[https://​www.shotcut.org/​download/​|la page officielle de téléchargement de Shotcut]], il est possible d'​installer Shotcut via Snap: +
-<​code>​snap install shotcut --classic</​code>​+
  
 +En vous rendant sur [[https://​snapcraft.io/​shotcut|Snapcraft]],​ installez **Shotcut**.
  
-==== Manuelle ​====+==== Au format appimage ​====
  
-<​note>​Cette installation est un peu dépassée bien que fonctionnelle. Privilégiez la version PPA.\\ +**Article dédié** au fonctionnement de cette méthode : [[:appimage]].
-En 32 bits, [[https://​github.com/​mltframework/​shotcut/​releases/​download/​v15.08/​shotcut-debian7-x86-150810.tar.bz2|télécharger la version 15.08.10]], dernière version 32 bits de Shotcut</​note>​+
  
-Pour installer ce logiciel, il faut :+Les fichiers se trouveront sur [[https://​www.fosshub.com/​Shotcut.html?​dwl|Fosshub]] ou [[https://​github.com/​mltframework/​shotcut/​releases/​|Github]].
  
-  - Télécharger le paquet correspondant à votre //version// (//​[[:​Ubuntu]]//,​ //​[[:​Fedora]]//​...) mais également à votre //​architecture//​ (32 bits ou 64 bits) dans la section **Download** du site officiel : [[http://​www.shotcut.org/​]] ; 
-  - Puis le [[:​archivage|décompresser]] à l'​endroit que vous aurez choisi et le lancer en cliquant sur son icône. 
-  - Sur Ubuntu 16.04, placer le dossier shotcut obtenu de préférence dans votre dossier personnel. Des dysfonctionnements peuvent en effet arriver si vous le laissez dans le dossier de téléchargement ou si vous le mettez dans un dossier particulier du dossier personnel. 
-  - Ouvrez alors shotcut à partir du raccourci contenu dans le dossier shotcut et si vous le désirez, vous pouvez laisser l'​icône dans le lanceur pour ouvrir plus rapidement shotcut ultérieurement. 
-  - En cas de problème au premier lancement, reportez-vous au § [[:​shotcut#​problemes_connus|problèmes connus]] 
  
 ===== Utilisation ===== ===== Utilisation =====
Ligne 59: Ligne 44:
 De nombreux tutoriels existent sur internet ou sur le site officiel du logiciel. de nouvelles versions sont très régulièrement disponibles (jusqu'​à une par mois) ajoutant des fonctionnalités ou corrigeant des bugs résiduels. N'​hésitez pas à visiter le site souvent. De nombreux tutoriels existent sur internet ou sur le site officiel du logiciel. de nouvelles versions sont très régulièrement disponibles (jusqu'​à une par mois) ajoutant des fonctionnalités ou corrigeant des bugs résiduels. N'​hésitez pas à visiter le site souvent.
  
-- Pour débuter et découvrir le logiciel, utilisez [[http://docplayer.fr/15125355-Premiers-pas-avec-shotcut.html|ce tutoriel de 15 pages en PDF]] écrit pour des élèves.+- Pour débuter et découvrir le logiciel, utilisez [[https://www.shotcut.org/howtos/​getting-started/​Premier%20pas%20avec%20Shotcut.pdf|ce tutoriel de 15 pages en PDF]] écrit pour des élèves.
  
 L'​utilisation des librairies open source pour les entrées et sorties permettent à Shotcut de gérer à peu près n'​importe quel format et fichier. L'​utilisation des librairies open source pour les entrées et sorties permettent à Shotcut de gérer à peu près n'​importe quel format et fichier.
Ligne 66: Ligne 51:
 ==== Formats d'​export ==== ==== Formats d'​export ====
 En fonction de l'​usage,​ personnel sur son PC, ou diffusé sur le web, il est difficile d'​exporter la vidéo dans le même format.\\ En fonction de l'​usage,​ personnel sur son PC, ou diffusé sur le web, il est difficile d'​exporter la vidéo dans le même format.\\
-[[wpfr>​Format_d%27affichage_vid%C3%A9o#/​media/​File:​Vector_Video_Standards.png|Les différentes tailles vidéo]]+[[wpfr>​Format_d'​affichage_vidéo|Les différentes tailles vidéo]] 
 =====Problèmes connus===== =====Problèmes connus=====
-Sous Ubuntu 16.10, après avoir installé le ppa, il peut survenir l'​erreur suivante : ''​shotcut : Dépend: libgstreamer-plugins-base0.10-0 qui n'est plus dans les dépôt 
-E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'​état ».''​ 
-Impossible, donc, d'​installer l'​application par ce moyen. FIXME \\ 
-Solution:\\ 
-Sous [[:​Xenial]],​ ce paquet est encore présent et son installation résout le problème.\\ 
-À la page suivante, [[https://​packages.ubuntu.com/​xenial/​libgstreamer-plugins-base0.10-0]]\\ 
-Installer avec les droits administrateur:​ 
-<​code>​apt install libgstreamer-plugins-base0.10-0</​code>​ 
  
 ==== Partage avec tous les utilisateurs ==== ==== Partage avec tous les utilisateurs ====
  • shotcut.1584557378.txt.gz
  • Dernière modification: Le 18/03/2020, 19:49
  • par 109.20.131.168