Contenu | Rechercher | Menus
Cette page n'a pas encore d'étiquettes.
Apportez votre aide…

Modèle : Sony VAIO VPC-EA1S1E

En un coup d’œil

Le tableau suivant récapitule la prise en charge du matériel de portable par les différentes versions d'Ubuntu. Il utilise les notations suivantes :

  • Fonctionne après config : Fonctionne après quelques manipulations
  • Fonctionne immédiatement : Fonctionne immédiatement
  • Pas testé : Pas d'informations disponibles
  • Ne fonctionne pas : Ne fonctionne pas
Version Installation Carte graphique Son Wifi Bluetooth Webcam Touchpad Raccourcis multimédia Autres
10.04 LTS (Lucid Lynx)

Utilisateurs du Wiki possédant cet ordinateur, fonctionnel :

Cet ordinateur portable n'est pas tatoué. 1)

Installation

Aucun problème lors de l'installation avec le live-CD ubuntu.

Pour créer les disques de sauvegarde Windows, il faut 3 dvd simples ( ou 2 dvd DL)

Comptez environ 2h pour faire graver ces sauvegardes.

:!: Attention à ce que l'ordinateur ne passe pas en veille pendant ce laps de temps (donc ne rabattez pas l'écran avec les réglages d'usine). Sinon la gravure s'interrompt et les disques sont fichus. Il faut alors tout regraver (je vous conseille d'utiliser des dvd-rw, quitte à les regraver ensuite sur des dvd-r, car l'interface n'est pas conviviale.

Pour info, voici la préinstallation usine Sony:

  • /dev/sda1: Partition recovery de Sony (Grub le reconnais comme partition "Windows Vista") 11.3 Gio
  • /dev/sda2: Boot Loader de Windows 104.9 Mio
  • /dev/sda3: Partition Windows 7 proprement dit >450 Gio

Si vous tentez de réduire la taille des partitions avec l'outils Windows, il ne permet pas de descendre en dessous de la moitié du volume du disque c: (soit env 250 Go)

Pas de problème pour réduire cette taille à ~50 Gio avec gparted, ou l'installateur ubuntu, il faut juste noter que les 3 partitions primaires sont déjà occupées, on est donc quasiment obligé de créer un partition logique pour pouvoir installer les partitions supplémentaire pour Ubuntu + swap + …

Ce n'est pas indispensable, mais cela accélère le repartitionnement de vérifier (scan) et défragmenter le disque avant de lancer l'installation.

Configuration du son

Lors de l'utilisation de votre ordinateur, si vous n'avez pas de son :

Méthode 1

Ouvrez un terminal

Puis copiez/collez ce qui suit ligne après ligne:

 sudo -s wget http://ftp.kernel.org/pub/linux/kernel/people/tiwai/misc/hda-verb/hda-verb-0.3.tar.gz
 tar xf hda-verb-0.3.tar.gz
 cd hda-verb-0.3
 make
 sudo cp hda-verb /usr/bin
 sudo gedit /etc/rc.local 

et ajouter cette ligne avant "exit 0" :

/usr/bin/hda-verb /dev/snd/hwC0D0 0x19 SET_PIN_WIDGET_CONTROL 0x22

enregistrez le fichier et fermez l'éditeur de texte.

Vous pouvez redémarrer votre ordinateur, le son devrait fonctionner.

Méthode 2

Il faut activer les backports, puis installer la bonne version d'alsa :

 sudo apt-get install linux-backports-modules-alsa-`uname -r`

Redémarrez, vous aurez du son! – testée par velanes

NB: cette commande est à renouveler après les mises à jour changeant la version du kernel.

Microphone

Pour enregistrer et faire fonctionner le micro, il faut désactiver la "sourdine" (mute) du micro dans les paramètres son qui sont actifs par défaut. Menu Système / Préférence / Sons, Onglet Entrée, case "sourdine" à décocher. (Personnellement j'ai calé le niveau du son d'enregistrement à 100%, mais à ajuster suivant le niveau sonore de vos sources audio pour ne pas saturer l'enregistrement).

Skype

Après le réglage du micro, fonctionne sans autre réglage (audio+vidéo)

A TESTER / REMARQUES DIVERSES

FIXME

  • réglage de l'intensité de l'écran: un fois le pilote ati installé, les touches lumi+ (Fn+F5) et lumi-(Fn+F6) ne sont pas active. Sans le pilote ATI, un OSD s'affiche, mais la luminosité n'est pas modifiée. (Ceci est réglé depuis la version 10.10 d'Ubuntu (Maverick Meerkat))
  • Pavé numérique: il ne s'active pas chez moi (mauvaise sélection de clavier ?)
  • Touches multimédias [Fn+]:
    • Audio: mute (F2), -(F3), +(F4): fonctionnent
    • Luminosité: (F5,F6) fonctionne depuis ubuntu 10.10 (cf. ci dessus)
    • Changement d'écran (F7): pas testé
    • Zoom (F9), (F10): pas de réaction
    • Mise en veille (F12): pas de réaction
    • Arr. Défil: ok pas testé
    • Pause : ok au boot, pas active sous Xorg
    • Attn : pas testée
  • Parkage des têtes: a priori pas le DD n'est pas touché par ce problème avec ubuntu 10.04

Pour le vérifier (nécessite le paquet smartmontools):

sudo smartctl -a /dev/sda
  • Touchpad: il fonctionne en multitouch (scroll comme sous windows), mais pas en multi-doigts ( comme sous mac)

Voir aussi


Contributeurs : leo.lsdb, Philémon-Eric, fnx

1) installation de grub sur /dev/sda n'empêche pas le dual boot avec Windows 7

sony_vaio_vpc-ea1s1e.txt · Dernière modification: Le 17/05/2012, 19:00 par mohican
Le contenu de ce wiki est sous licence : CC BY-SA v3.0