Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
acroread [Le 12/12/2018, 13:08]
109.7.55.182 [Adobe Reader] module XFA - plus précis
acroread [Le 11/06/2021, 14:25]
176.130.134.118 [Avec Wine]
Ligne 1: Ligne 1:
-{{tag>Trusty ​visionneuse pdf}}+{{tag>Bionic ​visionneuse pdf}}
  
 ---- ----
Ligne 22: Ligne 22:
 <note warning>​Au 4 aout 2016((**(en)** [[https://​askubuntu.com/​questions/​752425/​how-to-open-a-pdf-form-file-that-says-please-wait|Post de Nealncb]] — discussion : « How to open a PDF form file that says wait? » ; site : AskUbuntu.com)),​ **la note de certification ISO 32000-2** présentée et validée lors du scrutin des Accords Internationaux de Pretoria en Afrique du Sud **__préconise__ l'​abandon pur et simple du format XFA**. \\ <note warning>​Au 4 aout 2016((**(en)** [[https://​askubuntu.com/​questions/​752425/​how-to-open-a-pdf-form-file-that-says-please-wait|Post de Nealncb]] — discussion : « How to open a PDF form file that says wait? » ; site : AskUbuntu.com)),​ **la note de certification ISO 32000-2** présentée et validée lors du scrutin des Accords Internationaux de Pretoria en Afrique du Sud **__préconise__ l'​abandon pur et simple du format XFA**. \\
 __**Adobe Inc ne contrevient donc pas à des accords internationaux en poursuivant le développement du module XFA, mais son utilisation n'est plus conseillée**__.</​note>​ __**Adobe Inc ne contrevient donc pas à des accords internationaux en poursuivant le développement du module XFA, mais son utilisation n'est plus conseillée**__.</​note>​
-===== Pré-requis ===== +
-  +
-  * Disposer des [[:​sudo|droits d'​administration]]. +
-  * Disposer d'une connexion à Internet configurée et activée.+
  
 ===== Installation ===== ===== Installation =====
Ligne 33: Ligne 30:
  
 Ou bien directement en 32 bits [[http://​ardownload.adobe.com/​pub/​adobe/​reader/​unix/​9.x/​9.5.5/​enu/​AdbeRdr9.5.5-1_i386linux_enu.deb|ici]] ou [[http://​ardownload.adobe.com/​pub/​adobe/​reader/​unix/​9.x/​9.4.2/​fra/​AdbeRdr9.4.2-1_i386linux_fra.deb|là]] pour une version moins récente mais en français. Dans ces derniers cas il faudra pour les [[:​architecture_materielle|architecture 64 bits]] avoir [[:​tutoriel:​comment_installer_un_paquet|installé les paquets]] **[[apt>​libgtk2.0-0:​i386,​libnspr4-0d:​i386,​libxml2:​i386,​libxslt1.1:​i386,​libstdc++6:​i386]]**. Ou bien directement en 32 bits [[http://​ardownload.adobe.com/​pub/​adobe/​reader/​unix/​9.x/​9.5.5/​enu/​AdbeRdr9.5.5-1_i386linux_enu.deb|ici]] ou [[http://​ardownload.adobe.com/​pub/​adobe/​reader/​unix/​9.x/​9.4.2/​fra/​AdbeRdr9.4.2-1_i386linux_fra.deb|là]] pour une version moins récente mais en français. Dans ces derniers cas il faudra pour les [[:​architecture_materielle|architecture 64 bits]] avoir [[:​tutoriel:​comment_installer_un_paquet|installé les paquets]] **[[apt>​libgtk2.0-0:​i386,​libnspr4-0d:​i386,​libxml2:​i386,​libxslt1.1:​i386,​libstdc++6:​i386]]**.
- 
  
  
 ==== Via PlayOnLinux ==== ==== Via PlayOnLinux ====
 +Sous Ubuntu une
 L'​utilisation de [[:​PlayOnLinux]] est probablement la manière la plus simple quant à l'​installation d'une version récente d'​Adobe Reader… pour Microsoft Windows (à travers [[wine|Wine]]) :​ L'​utilisation de [[:​PlayOnLinux]] est probablement la manière la plus simple quant à l'​installation d'une version récente d'​Adobe Reader… pour Microsoft Windows (à travers [[wine|Wine]]) :​
   * Installer [[:​PlayOnLinux]],​   * Installer [[:​PlayOnLinux]],​
Ligne 46: Ligne 43:
 **Les nouvelles versions "​Reader DC"** sous Windows XP SP3 jusqu'​à Windows 7 - présentes sur le serveur d'​Adobe **ne sont plus compatibles Wine ou CrossOver**. En effet, l’installeur impose de télécharger des mises à jour ; cette procédure conduit à une erreur interne qui plante l'​installation. **Les nouvelles versions "​Reader DC"** sous Windows XP SP3 jusqu'​à Windows 7 - présentes sur le serveur d'​Adobe **ne sont plus compatibles Wine ou CrossOver**. En effet, l’installeur impose de télécharger des mises à jour ; cette procédure conduit à une erreur interne qui plante l'​installation.
 </​note>​ </​note>​
 +====Avec Wine====
 +Installer [[Wine]] et [[Winetricks]],​ puis executez:
 +<​code>​winetricks mspatcha</​code>​
 +Téléchargez la dernière versions d'​Acrobat [[https://​get.adobe.com/​fr/​reader/​enterprise/​|ici]] puis exécutez-le avec wine:
 +<​code>​wine AcroRdrDCxxxxxx.exe</​code>​
  
-<note tip>La seule option "​sécurisée"​ - entendez qu'​elle fait appel à un logiciel certes propriétairemais qui a l'avantage des mises à jour - reste Master PDF Editor® (version 3 courante). \\ Les paquets et archives sont disponibles sur la [[https://​code-industry.net/​free-pdf-editor/?​-update&​x&​ver=3710#​get|Page de téléchargement de l'​éditeur]]** (en) **.</​note>​ +Ouaprès ​l'installation de [[Wine]], tapez Acrobat dans la barre de recherche Shell et installez ​le depuis [[Logiciel]] ou [[Ubuntu Software]].
- +
-<note warning>​**La version gratuite** ​de Master PDF Editor **ne permet ni l’édition ni le chiffrement** du document visionné.</​note>​+
  
 ===== Configuration ===== ===== Configuration =====
Ligne 78: Ligne 78:
 Il est possible de remplir les fichiers CERFA directement en ligne, ce qui vous évite les problèmes liés à ce type de formulaires. Il est possible de remplir les fichiers CERFA directement en ligne, ce qui vous évite les problèmes liés à ce type de formulaires.
  
-30/​08/​2016: ​evince ​3.18 supporte assez bien les formulaires CERFA (cases à cocher, champ de code postal...)+30/08/2016 : Evince ​3.18 supporte assez bien les formulaires CERFA (cases à cocher, champ de code postal...)
  
-01/08/2018 : solution pour les cerfa, il existe des versions en odt : https://​www.service-public.fr/​associations/​vosdroits/​R1271 ​ 
 ==== Problème d'​imprimante avec Acrobat Reader ==== ==== Problème d'​imprimante avec Acrobat Reader ====
  
Ligne 96: Ligne 95:
 L'​impression fonctionne depuis **acroread**. L'​impression fonctionne depuis **acroread**.
  
-====Problème d'autocompletion==== +====Problème d'autocomplétion==== 
-Problème d'auto-completion ​ajoutant un espace lorsqu'​on utilise tab semble lié au fichier+Problème d'autocomplétion ​ajoutant un espace lorsqu'​on utilise tab semble lié au fichier
 /​opt/​Adobe/​Reader9/​Resource/​Shell/​acroread_tab. Voir [[https://​bugs.launchpad.net/​ubuntu/​+source/​gnome-terminal/​+bug/​768876|ici]]. /​opt/​Adobe/​Reader9/​Resource/​Shell/​acroread_tab. Voir [[https://​bugs.launchpad.net/​ubuntu/​+source/​gnome-terminal/​+bug/​768876|ici]].
  
 +====Texte manquant dans l'​interface====
 +Si une partie du texte de l'​interface graphique ne s'​affiche pas, téléchargez et installez les polices de caractères Segoe UI.
 =====Voir aussi===== =====Voir aussi=====
   * [[https://​bugs.launchpad.net/​ubuntu/​+source/​acroread/​+bug/​1176131|le bug qui réclame le paquet deb de la version 9.5.5 pour les dépôts Trusty]],   * [[https://​bugs.launchpad.net/​ubuntu/​+source/​acroread/​+bug/​1176131|le bug qui réclame le paquet deb de la version 9.5.5 pour les dépôts Trusty]],
  • acroread.txt
  • Dernière modification: Le 11/06/2021, 14:25
  • par 176.130.134.118