Docker-Compose

Docker compose permet de définir et exécuter de multiple conteneurs docker.
Pour plus d'informations, consulter la documentation officielle (en)

Depuis les dépôts officiels (conseillé)

apt install docker-compose

Avec le binaire

Comme la plupart des logiciels, la version obtenue par les dépôts officielles peut-être un peu ancienne

Docker-compose tient dans un fichier binaire, il est donc facile de passer à la dernière version ou à une version spécifique.
Tout d'abord, si vous aviez installé une précédente version, supprimez-la, par exemple si version des dépôts officiels :

sudo apt remove docker-compose

Puis télécharger la version que vous souhaitez à partir de https://github.com/docker/compose/releases par exemple, pour la v2.2.3 : https://github.com/docker/compose/releases/download/v2.2.3/docker-compose-linux-x86_64
puis déplacer le fichier dans :

sudo mv docker-compose-linux-x86_64 /usr/local/bin/docker-compose

puis le rendre exécutable :

sudo chmod +x /usr/local/bin/docker-compose

Vérifier que docker-compose s'appelle correctement :

docker-compose --version
# qui doit retourné une ligne du type :
Docker Compose version v2.2.3

Ces commandes toutes en un pour la mise à jour sur un serveur donne 1) :

wget https://github.com/docker/compose/releases/download/v2.2.3/docker-compose-linux-x86_64 && sudo mv docker-compose-linux-x86_64 /usr/local/bin/docker-compose && sudo chmod +x /usr/local/bin/docker-compose && docker-compose --version
La mise à jour peut-être faite alors que des containers tournent.
Sous bionic, la version de docker depuis les dépôt officiels est, en mars 2022, la v19.03.13 qui est compatible avec docker-compose v2

Si un docker-compose retourne l'erreur :

1 error occurred:
	* error listing credentials - err: exec: "docker-credential-secretservice": executable file not found in $PATH

dans le fichier ~/.docker/config.json, modifier le mot-clé credsStore par credStore2)


1)
ne le faites sur un serveur en production que si vous êtes sûr de ce que vous faites
  • docker-compose.txt
  • Dernière modification: Le 27/05/2022, 11:46
  • par bcag2