Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
flatpak [Le 06/02/2021, 07:49]
78.203.218.4 [Installation de logiciels]
flatpak [Le 20/07/2021, 16:34] (Version actuelle)
christophe c [Lancement de logiciels] astuce
Ligne 15: Ligne 15:
 Le projet est mené par freedesktop.org depuis 2014, jadis sous le nom de ''​xdg-app'',​ le but étant de faciliter la distribution d'​applications par des développeurs tiers sur toutes les distributions. Le projet est mené par freedesktop.org depuis 2014, jadis sous le nom de ''​xdg-app'',​ le but étant de faciliter la distribution d'​applications par des développeurs tiers sur toutes les distributions.
  
-Depuis 2017, beaucoup d'​applications populaires ​commencent à être disponibles au format Flatpak : [[:​Blender]],​ [[:Skype]], [[:​Spotify]],​ [[:​LibreOffice]],​ [[:​Pitivi]],​ certaines applications [[:KDE]], beaucoup d'​applications [[:GNOME]], beaucoup d'​applications //​elementaryOS//,​ etc.+Depuis 2017, beaucoup d'​applications populaires ​ont été rendues ​disponibles au format Flatpak : [[:​Blender]],​ [[:Skype]], [[:​Spotify]],​ [[:​LibreOffice]],​ [[:​Pitivi]],​ certaines applications [[:KDE]], beaucoup d'​applications [[:GNOME]], beaucoup d'​applications //​elementaryOS//,​ etc.
  
-Les applications récentes en cours de développement actif sont parfois même dans un premier temps disponibles presque uniquement sous forme de Flatpak !+Des applications récentes en cours de développement actif sont parfois même disponibles presque uniquement sous forme de Flatpak !
  
 ===== Pré-requis ===== ===== Pré-requis =====
Ligne 32: Ligne 32:
  
 - Le paquet **[[apt>​gnome-software-plugin-flatpak]]** (qui n'​existe pas pour la version 16.04) permet, optionnellement,​ de pouvoir gérer les logiciels Flatpak depuis la [[:​gnome-software|logithèque GNOME]]. - Le paquet **[[apt>​gnome-software-plugin-flatpak]]** (qui n'​existe pas pour la version 16.04) permet, optionnellement,​ de pouvoir gérer les logiciels Flatpak depuis la [[:​gnome-software|logithèque GNOME]].
 +
 - Le paquet **[[apt>​plasma-discover-flatpak-backend]]** (qui n'​existe pas pour la version 16.04) permet, optionnellement,​ de pouvoir gérer les logiciels Flatpak depuis la [[:​plasma-discover|logithèque KDE]]. - Le paquet **[[apt>​plasma-discover-flatpak-backend]]** (qui n'​existe pas pour la version 16.04) permet, optionnellement,​ de pouvoir gérer les logiciels Flatpak depuis la [[:​plasma-discover|logithèque KDE]].
  
Ligne 42: Ligne 43:
 ===== Configuration ===== ===== Configuration =====
  
-Les logiciels Flatpak ne viennent pas des dépôts d'​Ubuntu,​ mais de sites souvent alimentés directement par les développeurs. Il faut configurer ​ces dépôts avant de pouvoir installer quelque chose.+Les logiciels Flatpak ne viennent pas des dépôts d'​Ubuntu,​ mais de sites souvent alimentés directement par les développeurs. Il faut référencer ​ces dépôts ​dans Ubuntu ​avant de pouvoir installer quelque chose.
  
-**Voir le [[:​tutoriel/​installer_application_flatpak#​ajouter_le_depot_flathub|tutoriel dédié]] pour des explications détaillées.** +Le principal dépôt de logiciels au format Flatpak est **Flathub** ; il est explorable en ligne [[https://​flathub.org/​apps|ici]] sous forme de site web. Pour l'​explorer depuis la logithèque ou depuis le terminal, on peut l'​​ajouter comme une source de logiciels avec la commande :
- +
-Le principal dépôt de logiciels au format Flatpak est **Flathub** ; il est explorable en ligne [[https://flathub.org/​apps|ici]] sous forme de site web. Pour l'​explorer depuis la logithèque ou depuis le terminal, on peut l'​​ajouter comme une source de logiciels avec la commande :+
  
 <code bash>​flatpak remote-add --if-not-exists flathub https://​flathub.org/​repo/​flathub.flatpakrepo</​code>​ <code bash>​flatpak remote-add --if-not-exists flathub https://​flathub.org/​repo/​flathub.flatpakrepo</​code>​
  
-Votre logithèque ​intègrera ​désormais les programmes disponibles sur ce dépôt.+Votre logithèque ​intégrera ​désormais les programmes disponibles sur ce dépôt
 + 
 +Pour installer d'​autres dépôts, voir le [[:​tutoriel/​installer_application_flatpak#​ajouter_le_depot_flathub|tutoriel dédié]] à l'​installation des dépôts flatpak.
  
 ===== Utilisation ===== ===== Utilisation =====
Ligne 68: Ligne 69:
 **Voir le [[:​tutoriel/​installer_application_flatpak|tutoriel dédié]].** **Voir le [[:​tutoriel/​installer_application_flatpak|tutoriel dédié]].**
  
-Une fois les dépôts configurés,​ on peut installer ​les logiciels en provenance de **Flathub** directement depuis la logithèque.+1. Soit directement à partir du site [[https://​flathub.org/​home|Flathub]] (ce site est également un magasin d'​application). 
 + 
 +2. Soit à partir de la logithèque (si le plugin logithèque a bien été installé). Les logiciels flatpak y sont mélangés avec les logiciels au format .deb. On peut les reconnaître sur la page du logiciel : la zone **source** indique le dépôt : **dl.flathub.org** pour flathub, par exemple.
  
-Ou bien, en ligne de commande :+3. Soit en ligne de commande :
  
 <​code>​flatpak install nom_du_depot identifiant.du.logiciel</​code>​ <​code>​flatpak install nom_du_depot identifiant.du.logiciel</​code>​
 +donc avec flahub : 
 +<​code>​flatpak install flathub identifiant.du.logiciel</​code>​
  
 <note help>Le premier logiciel que vous installerez sera peut-être long à installer car le système téléchargera un __environnement d'​exécution__,​ qui pourra être réutilisé par les logiciels en format Flatpak installés par la suite.</​note>​ <note help>Le premier logiciel que vous installerez sera peut-être long à installer car le système téléchargera un __environnement d'​exécution__,​ qui pourra être réutilisé par les logiciels en format Flatpak installés par la suite.</​note>​
Ligne 115: Ligne 120:
 Il s'agit d'un exemple pour illustrer qu'​avec la syntaxe simplifiée,​ la commande a toujours besoin de connaître le dépôt et l'​identifiant exact du logiciel, mais le cas présenté est intentionnellement plus bavard que la moyenne. Il s'agit d'un exemple pour illustrer qu'​avec la syntaxe simplifiée,​ la commande a toujours besoin de connaître le dépôt et l'​identifiant exact du logiciel, mais le cas présenté est intentionnellement plus bavard que la moyenne.
  
 +==== Connaître les logiciels installés ====
 +Au terminal, tapez :
 +<​code>​flatpak list</​code>​
 ==== Lancement de logiciels ==== ==== Lancement de logiciels ====
  
Ligne 122: Ligne 130:
 <​code>​flatpak run identifiant.du.logiciel</​code>​ <​code>​flatpak run identifiant.du.logiciel</​code>​
  
-<note tip>Utilisez ​tabulation pour voir les noms exacts des applications installées</​note>​+<note tip>Astuce : tapez **flatpak run** + la 1er lettre du nom complet du logiciel, et utilisez **tabulation** pour voir les noms exacts des applications installées ​correspondantes</​note>​
  
 ==== Mise à jour des logiciels ==== ==== Mise à jour des logiciels ====
Ligne 135: Ligne 143:
 Les logiciels en format Flatpak peuvent être désinstallés de la même manière que les autres par la logithèque (onglet "​Installées"​). Les logiciels en format Flatpak peuvent être désinstallés de la même manière que les autres par la logithèque (onglet "​Installées"​).
  
-Une application au format flatpak peut être aussi retiré ​avec la commande ​+Une application au format flatpak peut être aussi retirée ​avec la commande ​
 <​code>​flatpak uninstall identifiant.du.logiciel</​code>​ <​code>​flatpak uninstall identifiant.du.logiciel</​code>​
 Pour supprimer les dépendances obsolètes c'est l'​option --unused à coupler avec uninstall Pour supprimer les dépendances obsolètes c'est l'​option --unused à coupler avec uninstall
  • flatpak.1612594173.txt.gz
  • Dernière modification: Le 06/02/2021, 07:49
  • par 78.203.218.4