Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
hplip [Le 26/11/2020, 21:05]
grigouille lien mort hp-scan
hplip [Le 02/09/2021, 08:44] (Version actuelle)
86.215.34.61 ancienne révision (Le 23/07/2021, 13:17) restaurée
Ligne 8: Ligne 8:
  
 La compagnie Hewlett-Packard a développé des pilotes pour l'​impression sous [[:​gnu|GNU]]/​[[:​linux|Linux]] pour la plupart de ses imprimantes. En fait, HP est très actif à l'​égard de l'​open-source et veille à ce que ses périphériques fonctionnent le mieux possible sur les systèmes [[:​gnu|GNU]]/​[[:​linux|Linux]]. La compagnie Hewlett-Packard a développé des pilotes pour l'​impression sous [[:​gnu|GNU]]/​[[:​linux|Linux]] pour la plupart de ses imprimantes. En fait, HP est très actif à l'​égard de l'​open-source et veille à ce que ses périphériques fonctionnent le mieux possible sur les systèmes [[:​gnu|GNU]]/​[[:​linux|Linux]].
-<note important>​ 
-Avec Ubuntu 20.04(.1), les commandes d'​impression par liaison USB de certaines imprimantes HP ne fonctionnent pas. 
  
-Contournement du problème : 
- 
-imprimante connectée, supprimer l'​installation de l'​imprimante : <code bash>​hp-setup -ir</​code>​ 
-désinstaller le paquet ippusbxd : <code bash>​sudo apt-get remove ippusbxd</​code>​ 
-arrêter et relancer l'​imprimante et le PC, 
- 
-réinstaller l'​imprimante : <code bash>​hp-setup</​code>​ 
- 
-Référence : [[http://​forum.ubuntu-fr.org/​viewtopic.php?​id=2053408|Discussion sur le forum]] 
-</​note>​ 
 ===== Connaître son imprimante ===== ===== Connaître son imprimante =====
   * Allez sur [[https://​developers.hp.com/​hp-linux-imaging-and-printing/​supported_devices/​index|Supported Printers]] et cherchez votre imprimante.   * Allez sur [[https://​developers.hp.com/​hp-linux-imaging-and-printing/​supported_devices/​index|Supported Printers]] et cherchez votre imprimante.
Ligne 33: Ligne 21:
  
 ===== Installation via hp-setup ===== ===== Installation via hp-setup =====
-C'est le programme [[https://​developers.hp.com/​hp-linux-imaging-and-printing/​tech_docs/​man_pages/​setup|hp-setup]] qui se charge d'​installer votre imprimante. Il peut se lancer en mode graphique ou en ligne de commande.+C'est le programme [[https://​developers.hp.com/​hp-linux-imaging-and-printing/​tech_docs/​man_pages/​setup|hp-setup]] qui se charge d'​installer votre imprimante. Il peut se lancer en mode graphique ou en ligne de commande. Il faut être dans le group ''​lpadmin''​ pour pouvoir installer l'​imprimante.
  
 ==== Le paquet hplip==== ==== Le paquet hplip====
Ligne 92: Ligne 80:
 === mode automatique (USB, réseau ou port parallèle)=== === mode automatique (USB, réseau ou port parallèle)===
 <code bash>​hp-setup -ia</​code>​ <code bash>​hp-setup -ia</​code>​
-==== En réseau ​====+=== En réseau ===
 <code bash>​hp-setup -i adresse_ip_de_l_imprimante</​code>​ <code bash>​hp-setup -i adresse_ip_de_l_imprimante</​code>​
 Remplacez ''​adresse_ip_de_l_imprimante''​ par l'​adresse IP de votre imprimante. L'​imprimante peut vous donner son adresse si elle possède un "​panneau avant"​. Remplacez ''​adresse_ip_de_l_imprimante''​ par l'​adresse IP de votre imprimante. L'​imprimante peut vous donner son adresse si elle possède un "​panneau avant"​.
Ligne 149: Ligne 137:
   * Une autre possibilité est de le télécharger directement [[http://​www.openprinting.org/​download/​printdriver/​auxfiles/​HP/​plugins/​|ici]] puis de l'​installer manuellement :<​code>​sudo sh hplip-x.xx.xx-plugin.run</​code>​   * Une autre possibilité est de le télécharger directement [[http://​www.openprinting.org/​download/​printdriver/​auxfiles/​HP/​plugins/​|ici]] puis de l'​installer manuellement :<​code>​sudo sh hplip-x.xx.xx-plugin.run</​code>​
  
 +Attention, au cas où une autre installation de Python comme Anaconda est présente, cette dernière peut entrer en conflit et poser problème à l'​installation du plugin. Dans ce cas, suivre les instructions [[hplip#​mot_de_passe_root_demande|ici]].
 ===== Installation de la boîte à outils ===== ===== Installation de la boîte à outils =====
 {{:​materiel:​imprimantes_hp:​hp-toolbox_precise.png?​300}} {{:​materiel:​imprimantes_hp:​hp-toolbox_precise.png?​300}}
Ligne 166: Ligne 155:
 Cette méthode concerne ceux qui ont une imprimante très récente et que la version actuelle d'​Ubuntu ne prend pas encore en charge. Cette méthode concerne ceux qui ont une imprimante très récente et que la version actuelle d'​Ubuntu ne prend pas encore en charge.
 <note important>​Dans le cas d'​Ubuntu 20.04 si l'​installation automatique échoue, il faudra faire une installation "​custom"​ sans interface graphique.</​note>​ <note important>​Dans le cas d'​Ubuntu 20.04 si l'​installation automatique échoue, il faudra faire une installation "​custom"​ sans interface graphique.</​note>​
 +<note tip> Pour ubuntu 20.04 une solution pour garder l'​installation automatique est de forcer python3 comme ceci: 
 +</​note>​ 
 +<code bash>​sudo apt install python-is-python3</​code>​ 
 +Cela permet de garder l'​installation en automatique et d’être plus simple, pour l'​installation du scanner ​
  
 Téléchargez la dernière version depuis cette [[https://​developers.hp.com/​hp-linux-imaging-and-printing|page]].\\ Téléchargez la dernière version depuis cette [[https://​developers.hp.com/​hp-linux-imaging-and-printing|page]].\\
Ligne 283: Ligne 275:
 </​code>​ </​code>​
  
-Choisir l'​option sans support graphique :+Choisir l'​option sans support graphique ​et sans le fax :
 <code bash> <code bash>
 Do you wish to enable '​Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? n Do you wish to enable '​Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? n
 +Do you wish to enable 'PC Send Fax support'​ (y=yes*, n=no, q=quit) ? n
 </​code>​ </​code>​
 +Pour les autres questions, prenez le choix par défaut (celui avec *).
 Au moment d'​installer l'​imprimante choisir le mode interactif : Au moment d'​installer l'​imprimante choisir le mode interactif :
 <code bash> <code bash>
Ligne 300: Ligne 293:
  
 Voici un exemple : https://​forum.ubuntu-fr.org/​viewtopic.php?​id=2057055 Voici un exemple : https://​forum.ubuntu-fr.org/​viewtopic.php?​id=2057055
 +
 +==== Problèmes d'​installation connus ====
 +
 +=== Mot de passe root demandé ===
 +
 +Lors de l'​installation,​ il se peut que le logiciel affiche le message ''​ENTER ROOT/​SUPERUSER PASSWORD''​ et que, si l'on entre le mot de passe de l'​utilisateur (disposant des droits d'​administrateurs),​ on obtienne une erreur. Ceci est dû au fait qu'​HPLIP,​ écrit en Python, utilise une version différente de Python que prévu. En particulier,​ au cas où Python aurait été également installé avec [[https://​doc.ubuntu-fr.org/​python#​anaconda|Anaconda]],​ hplip utilise cette installation au lieu de l'​installation système, ce qui contraint l'​installateur à utiliser la procédure d'​installation de Debian au lieu de celle d'​Ubuntu.
 +
 +**Solution**:​ dans le fichier ''​.bashrc'',​ il est nécessaire de commenter le bloc Anaconda qui ajoute l'​installation d'​anaconda au PATH. Typiquement,​ on commentera les lignes entre ''>>>​ conda initialize >>>''​ et ''<<<​ conda initialize <<<''​ au moyen du symbole ''#''​ le temps de l'​installation. Si la modification a fonctionné,​ le message devrait être transformé en ''​ENTER THE SUDOER'​S PASSWORD''​. Après avoir installé hplip, on peut décommenter ces lignes.
 +
 +Référence: ​
 +
 +    * [[https://​askubuntu.com/​questions/​1070477/​install-hplip-does-not-accept-root-password]]:​ sujet sur Askubuntu
 +    * [[https://​doc.ubuntu-fr.org/​personnaliser_path]]:​ plus d'​informations sur la variable d'​environnement PATH
  
 ===== Désinstaller la dernière version de HPLIP ===== ===== Désinstaller la dernière version de HPLIP =====
Ligne 305: Ligne 311:
   * Déplacez-vous dans notre dossier HPLIP généré pendant la [[:​tutoriel:​compiler_linux|compilation]] : <code bash>cd /​emplacement/​du/​dossier_hplip-numéro_version</​code>​   * Déplacez-vous dans notre dossier HPLIP généré pendant la [[:​tutoriel:​compiler_linux|compilation]] : <code bash>cd /​emplacement/​du/​dossier_hplip-numéro_version</​code>​
   * Ensuite nous désinstallons notre logiciel [[:​tutoriel:​compiler_linux|compilé]] : <code bash>​sudo make uninstall</​code>​   * Ensuite nous désinstallons notre logiciel [[:​tutoriel:​compiler_linux|compilé]] : <code bash>​sudo make uninstall</​code>​
 +<note warning>​Veillez à être très attentif aux commandes citées ci-dessous. Une erreur de votre part peut rendre votre système d'​exploitation inutilisable !</​note> ​
   * Il est maintenant nécessaire de supprimer les résidus de configuration de HPLIP : <code bash>​sudo rm -rf /​usr/​share/​hplip   * Il est maintenant nécessaire de supprimer les résidus de configuration de HPLIP : <code bash>​sudo rm -rf /​usr/​share/​hplip
 sudo rm -rf /etc/hp sudo rm -rf /etc/hp
 sudo rm -rf ~/.hplip sudo rm -rf ~/.hplip
-sudo rm -rf /​var/​lib/​hp</​code>​ +sudo rm -rf /​var/​lib/​hp</​code>​  
-  +
-<note warning>​Veillez à être très attentif aux commandes citées ci-dessous. Une erreur de votre part peut rendre votre système d'​exploitation inutilisable !</​note>​+
 ===== Problèmes ===== ===== Problèmes =====
 +==== Erreur d'​impression via USB (Ubuntu 20.04.1) ====
 +
 +
 +Avec Ubuntu 20.04(.1)FIXME((Bug rapporté sur Launchpad? Autres versions impactées : 20.04, 20.10?)), les commandes d'​impression par liaison USB de certaines imprimantes HP ne fonctionnent pas.
 +
 +Contournement du problème :
 +
 +imprimante connectée, supprimer l'​installation de l'​imprimante : <code bash>​hp-setup -ir</​code>​
 +désinstaller le paquet ippusbxd : <code bash>​sudo apt-get remove ippusbxd</​code>​
 +arrêter et relancer l'​imprimante et le PC,
 +
 +réinstaller l'​imprimante : <code bash>​hp-setup</​code>​
 +
 +Référence : [[http://​forum.ubuntu-fr.org/​viewtopic.php?​id=2053408|Discussion sur le forum]]
 +
 ==== Impossible d'​installer le greffon propriétaire ==== ==== Impossible d'​installer le greffon propriétaire ====
 Si après une mise à niveau vers une autre version d'​Ubuntu : Si après une mise à niveau vers une autre version d'​Ubuntu :
Ligne 349: Ligne 370:
   * [[http://​hplipopensource.com/​node/​276|How are HPLIP and HPIJS related?]]   * [[http://​hplipopensource.com/​node/​276|How are HPLIP and HPIJS related?]]
 ===== Références ===== ===== Références =====
-  * **(en)** [[http://hplipopensource.com/|Le site du projet hplip]] ​+  * **(en)** [[https://developers.hp.com/​hp-linux-imaging-and-printing/|Le site du projet hplip]] ​
   * **(en)** [[https://​launchpad.net/​hplip|Hplip sur Launchpad]],​ pour les questions et les rapports de bogues   * **(en)** [[https://​launchpad.net/​hplip|Hplip sur Launchpad]],​ pour les questions et les rapports de bogues
   * **(en)** [[wu>​HardwareSupportComponentsPrintersHp|Imprimantes HP supportées]] sur wiki.ubuntu.com   * **(en)** [[wu>​HardwareSupportComponentsPrintersHp|Imprimantes HP supportées]] sur wiki.ubuntu.com
  • hplip.1606421115.txt.gz
  • Dernière modification: Le 26/11/2020, 21:05
  • par grigouille