Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
imprimante_canon_capt2 [Le 22/10/2017, 13:46]
murex Suite MàJ pilote 271
imprimante_canon_capt2 [Le 09/07/2021, 17:51]
L'Africain focal ok
Ligne 1: Ligne 1:
-{{tag>Xenial ​matériel imprimante Canon}}+{{tag>Focal matériel imprimante Canon}}
 ---- ----
  
 ====== Installer le pilote d'​imprimantes Canon CAPT ====== ====== Installer le pilote d'​imprimantes Canon CAPT ======
    
-**[[:​liste_imprimantes_canon|Consulter la liste des imprimantes Canon]] pour savoir si votre imprimante est supportée par ce pilote ​propriétaire((Le code source des pilotes propriétaires n'est pas librement accessible et modifiable par les développeurs d'​Ubuntu)) ​fourni par Canon.**+**[[:​liste_imprimantes_canon|Consulter la liste des imprimantes Canon]] pour savoir si votre imprimante est supportée par ce pilote fourni par Canon.**
  
-<​note ​importante>Sous Ubuntu 16.04, ou bien cela est lié au dernier pilote de Canon (la version 2.7x), de nombreux ​problème subsiste ​avec la LBP2900 et peut-être d'​autres LBP. Une solution est proposée [[https://​askubuntu.com/​questions/​956674/​how-to-make-canon-lbp2900b-work-on-ubuntu-16-04-lts|ici]]+<​note ​warning>Sous Ubuntu 16.04 et ultérieur, ou bien cela est lié au dernier pilote de Canon (la version 2.7x), de nombreux ​problèmes subsistent ​avec la LBP2900 et peut-être ​d'​autres LBP. Un [[pilote_canon_capt_alternatif|pilote alternatif]] a été développé et fonctionne très bien avec ce modèle et probablement ​d'​autres LBP. Une autre solution est proposée [[https://​askubuntu.com/​questions/​956674/​how-to-make-canon-lbp2900b-work-on-ubuntu-16-04-lts|ici]].
  <​sup>​**en**</​sup>,​ (installer le pilote 32 bits en 64 bits) et [[https://​forum.ubuntu-fr.org/​viewtopic.php?​id=2010140|là]] <​sup>​**fr**</​sup>​.</​note>​  <​sup>​**en**</​sup>,​ (installer le pilote 32 bits en 64 bits) et [[https://​forum.ubuntu-fr.org/​viewtopic.php?​id=2010140|là]] <​sup>​**fr**</​sup>​.</​note>​
 +<note importante>​Si cette page ne vous a pas aidé à faire fonctionner votre imprimante vous pouvez toujours essayer le [[pilote_canon_capt_alternatif|pilote alternatif]].</​note>​
 +
 ===== Téléchargement du pilote Canon CAPT ===== ===== Téléchargement du pilote Canon CAPT =====
 Le pilote Canon CAPT se présente sous la forme d'un fichier unique de type archive au format **[[:​tar|tar.gz]]**.\\ Le pilote Canon CAPT se présente sous la forme d'un fichier unique de type archive au format **[[:​tar|tar.gz]]**.\\
-Cette archive d'​environ 127 Mo nommée : **linux-capt-drv-v271-uken.tar.gz** est à télécharger **[[http://support-sg.canon-asia.com/contents/SG/EN/0100459601.html|ici]]**.+Cette archive d'​environ 127 Mo nommée : **linux-capt-drv-v271-uken.tar.gz** est à télécharger **[[https://​sg.canon/​en/support/0100459601/7|ici]]**.
  
  
Ligne 26: Ligne 28:
 ===== Installation du pilote Canon CAPT ===== ===== Installation du pilote Canon CAPT =====
  
-Le pilote Canon CAPT nécessite l'​[[:​tutoriel:​comment_installer_un_paquet|installation ​du paquet]] : **[[apt>​libglade2-0]]** \\ +Le pilote Canon CAPT nécessite l'​[[:​tutoriel:​comment_installer_un_paquet|installation ​des paquets]] : **[[apt>​libglade2-0,​libcanberra-gtk-module]]** \\ 
  
 <​note>​Vérifier que l'​imprimante est allumée et connectée à l'​ordinateur.</​note>​ <​note>​Vérifier que l'​imprimante est allumée et connectée à l'​ordinateur.</​note>​
Ligne 54: Ligne 56:
  
 === Pour les versions Ubuntu 64 bits === === Pour les versions Ubuntu 64 bits ===
-Le pilote CAPT nécessite aussi l'​installation des paquets 32bits suivants : **[[apt>​libatk1.0-0:​i386,​libcairo2:​i386,​libgtk2.0-0:​i386,​libpango1.0-0:​i386,​libstdc++6:​i386,​libxml2:​i386,​libpopt0:​i386]]** \\ +Le pilote CAPT nécessite aussi l'​installation des paquets 32bits suivants : **[[apt>​libatk1.0-0:​i386,​libcairo2:​i386,​libgtk2.0-0:​i386,​libpango1.0-0:​i386,​libstdc++6:​i386,​libxml2:​i386,​libpopt0:​i386,​zlib1g:​i386,​libc6:i386]]** \\ 
  
  
Ligne 74: Ligne 76:
 ==== Relancer CUPS ==== ==== Relancer CUPS ====
 Pour que l'​installation du pilote CAPT soit prise en compte par [[:CUPS]], entrer les commandes suivantes dans un [[:​terminal]] :  Pour que l'​installation du pilote CAPT soit prise en compte par [[:CUPS]], entrer les commandes suivantes dans un [[:​terminal]] : 
-<​code>​sudo ​service cups stop</​code>​ +<​code>​sudo ​systemctl ​stop cups</​code>​ 
-<​code>​sudo ​service cups start</​code>​+<​code>​sudo ​systemctl ​start cups</​code>​
 \\ \\
  
Ligne 265: Ligne 267:
  
 Une fois correctement installée, pour que l'​imprimante fonctionne d'une façon transparente pour l'​utilisateur,​ il faut automatiser le démarrage du démon ccpd. \\  Une fois correctement installée, pour que l'​imprimante fonctionne d'une façon transparente pour l'​utilisateur,​ il faut automatiser le démarrage du démon ccpd. \\ 
- 
- 
-<note important>​Vérifier bien **quelle version d'​Ubuntu** vous utilisez et exécutez les opérations correspondantes. \\ En cas d'​erreur celà peut provoquer des difficulté de fonctionnement du système. </​note>​ 
- 
-==== Pour la version 14.04 ==== 
-[[:​tutoriel:​comment_modifier_un_fichier|Créez avec les droits d'​administration]] un fichier : **/​etc/​init/​ccpd-start.conf** pour y insérer ceci: 
- 
-<​file>​ 
-# ccpd-start - Lance ccpd  
-  
-description ​   "Start daemon ccpd for Canon printers"​ 
- 
-start on runlevel [2345] 
-stop on runlevel [016] 
- 
-exec /​etc/​init.d/​ccpd start 
- 
-</​file> ​ 
- 
-Terminez en enregistrant ce fichier.\\ 
  
  
  • imprimante_canon_capt2.txt
  • Dernière modification: Le 09/07/2021, 17:51
  • par L'Africain