Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
migration [Le 13/12/2017, 11:00]
193.55.175.20 [J'ai déjà commencé la mise à niveau, et elle est lente. Puis-je l'arrêter puis la reprendre plus tard ?]
migration [Le 14/11/2021, 07:32] (Version actuelle)
malbo supression de la mention "guide de mise à niveau de la version qui vous concerne" motif : il n'y a plus de guide -
Ligne 1: Ligne 1:
 {{tag>​portail installation}} {{tag>​portail installation}}
 ----- -----
 +======Mise à niveau (migration)======
  
-====== Mise à niveau ​(migration) ======+Ce document d'​introduction répond aux questions les plus courantes concernant la mise à niveau ​d'​Ubuntu et ses variantes vers une version ultérieure. Nous vous rappelons qu'une mise à niveau n'est pas à prendre à la légère, d'où la raison pour laquelle nous vous invitons fortement à prendre connaissance du présent document avant de procéder.
  
-Ce document d'​introduction répond aux questions les plus courantes concernant la mise à niveau d'​Ubuntu et ses variantes vers une version ultérieure. Nous vous rappelons qu'une mise à niveau n'est pas à prendre à la légère, d'où la raison pour laquelle nous vous invitons fortement à prendre connaissance du présent document et du [[#​guides_specifiques_de_mise_a_niveau|guide de mise à niveau de la version qui vous concerne]] avant de procéder. 
  
-===== Mise à niveau et mise à jour : quelle différence ?=====+===== Mise à niveau et mise à jour : quelle différence ? =====
  
-Le terme **« mise à niveau »**, ou //« migration »//, est un processus qui permet de passer d'une ancienne [[:​versions|version]] d'​Ubuntu (ou d'une de ses [[:​variantes]]) à une version plus récente de la distribution. Un exemple de mise à niveau est le passage ​d'une installation courante d'Ubuntu ​12.10 à une version ultérieure, ​Ubuntu ​13.04. Utiliser la toute dernière version d'​Ubuntu peut être intéressant car celle-ci gère de plus en plus de nouveaux matériels et périphériques,​ et est toujours plus optimisée dans l'​utilisation des ressources de votre ordinateur //(cf. [[#​la_mise_a_niveau_est-elle_obligatoire_est-elle_utile_pour_moi|"​La mise à niveau est-elle utile pour moi ?"​]])//​.+Le terme **« mise à niveau »**, ou //« migration »//, est un processus qui permet de passer d'une ancienne [[:​versions|version]] d'​Ubuntu (ou d'une de ses [[:​variantes]]) à une version plus récente de la distribution. Un exemple de mise à niveau est le passage ​de Ubuntu ​19.10 à Ubuntu ​20.04. Utiliser la toute dernière version d'​Ubuntu peut être intéressant car celle-ci gère de plus en plus de nouveaux matériels et périphériques,​ et est toujours plus optimisée dans l'​utilisation des ressources de votre ordinateur //(cf. [[#​la_mise_a_niveau_est-elle_obligatoire_est-elle_utile_pour_moi|"​La mise à niveau est-elle utile pour moi ?"​]])//​.
  
 La **mise à niveau** est à différencier d'une simple [[:mise à jour]] : La **mise à niveau** est à différencier d'une simple [[:mise à jour]] :
Ligne 14: Ligne 14:
   * la mise à niveau (migration) implique //un passage de votre version d'​Ubuntu à une version ultérieure//​. Lors d'une mise à niveau, le migrateur fait passer vos logiciels en une version plus récente, de même qu'​installe,​ remplace ou désinstalle certains logiciels nouveaux ou, au contraire, obsolètes. //La mise à niveau **a un impact en profondeur** sur votre système//, et doit être faite en connaissance de cause.   * la mise à niveau (migration) implique //un passage de votre version d'​Ubuntu à une version ultérieure//​. Lors d'une mise à niveau, le migrateur fait passer vos logiciels en une version plus récente, de même qu'​installe,​ remplace ou désinstalle certains logiciels nouveaux ou, au contraire, obsolètes. //La mise à niveau **a un impact en profondeur** sur votre système//, et doit être faite en connaissance de cause.
  
-=== Ubuntu ​16.10 vers Ubuntu ​17.04: est-ce une mise à jour ou mise à niveau ? ===+==== Ubuntu ​18.04 LTS vers Ubuntu ​18.10 : est-ce une mise à jour ou mise à niveau ? ===
 Il s'agit d'une **mise à niveau**. Vous passez votre système Ubuntu d'une version quelconque vers une version plus récente. Le passage à une nouvelle version implique des changements majeurs, en profondeur, tels des nouveaux logiciels, des nouveaux services et des nouveaux [[:​kernel|noyaux Linux]]. Il s'agit donc d'une mise à niveau. Il s'agit d'une **mise à niveau**. Vous passez votre système Ubuntu d'une version quelconque vers une version plus récente. Le passage à une nouvelle version implique des changements majeurs, en profondeur, tels des nouveaux logiciels, des nouveaux services et des nouveaux [[:​kernel|noyaux Linux]]. Il s'agit donc d'une mise à niveau.
  
-=== Et de Ubuntu ​14.04 LTS à Ubuntu ​14.04.LTS: mise à jour ou mise à niveau ? === +==== Et de Ubuntu ​18.04 LTS à Ubuntu ​18.04.LTS : mise à jour ou mise à niveau ? ====
-Il s'agit d'une mise à jour importante marquant une étape dans les [[:​lts|versions LTS d'​Ubuntu]]. La version 14.04.5 d'​Ubuntu n'​inclut pas de nouvelles applications ni des nouveaux services. Il s'agit d'une compilation des derniers correctifs de sécurité ou/et une utilisation du binôme //​[[:​kernel|noyau]]/​serveur graphique// de version supérieure. Ceci est donc une mise à jour.\\ +
-Voir cette [[:​ltsenablementstack|page]] pour en savoir plus sur ce type de mise à jour.+
  
 +Il s'agit d'une **mise à jour** importante marquant une étape dans les [[:​lts|versions LTS d'​Ubuntu]]. La version 18.04.1 d'​Ubuntu n'​inclut pas de nouvelles applications ni de nouveaux services. Il s'agit d'une compilation des derniers correctifs de sécurité ou/et une utilisation du binôme //​[[:​kernel|noyau]]/​serveur graphique// de version supérieure. Ceci est donc une mise à jour.
 +
 +Voir cette [[:​ltsenablementstack|page]] pour en savoir plus sur ce type de mise à jour.
  
 ===== La mise à niveau est-elle obligatoire ? Est-elle utile pour moi ? ===== ===== La mise à niveau est-elle obligatoire ? Est-elle utile pour moi ? =====
Ligne 29: Ligne 31:
 Si votre environnement nécessite une stabilité accrue et homogène (p. ex. : les milieux d'​entreprise),​ utiliser des [[:​lts|versions soutenues à long terme (LTS)]] est recommandé,​ car elles sont soutenues et bénéficient de mises à jour de sécurité pour une période prolongée pendant 5 ans pour les versions desktop et serveur depuis la version 12.04 LTS. Effectuez des mises à niveau de version LTS à version LTS+1 lorsque votre version actuelle arrive en fin de vie. Si votre environnement nécessite une stabilité accrue et homogène (p. ex. : les milieux d'​entreprise),​ utiliser des [[:​lts|versions soutenues à long terme (LTS)]] est recommandé,​ car elles sont soutenues et bénéficient de mises à jour de sécurité pour une période prolongée pendant 5 ans pour les versions desktop et serveur depuis la version 12.04 LTS. Effectuez des mises à niveau de version LTS à version LTS+1 lorsque votre version actuelle arrive en fin de vie.
  
-<note help>​**//​« Ma version d'​Ubuntu arrive prochainement ou est arrivée en fin de vie. Suis-je obligé de procéder à une mise à niveau ? »//** \\ Dans l'​absolu,​ vous n'​êtes pas obligé de procéder à une mise à niveau, car Ubuntu ne contient aucun mécanisme bloquant l'​utilisation d'une version non-soutenue. Toutefois, utiliser une version non-soutenue n'est pas recommandé car :+<note help>​**//​« Ma version d'​Ubuntu arrive prochainement ou est arrivée en fin de vie. Suis-je obligé de procéder à une mise à niveau ? »//** \\ Dans l'​absolu,​ vous n'​êtes pas obligé de procéder à une mise à niveau, car Ubuntu ne contient aucun mécanisme bloquant l'​utilisation d'une version non-soutenue. Toutefois, utiliser une version non soutenue n'est pas recommandé car :
   * vous n'​obtiendrez plus d '​assistance((La documentation ubuntu-fr ne contient pas d'​informations concernant les versions obsolètes, et peu d'​utilisateurs du forum sauront vous guider car n'​utilisant pas la même version que vous.)) ;   * vous n'​obtiendrez plus d '​assistance((La documentation ubuntu-fr ne contient pas d'​informations concernant les versions obsolètes, et peu d'​utilisateurs du forum sauront vous guider car n'​utilisant pas la même version que vous.)) ;
   * et les éventuelles failles de sécurités affectant vos logiciels ne seront plus corrigées.   * et les éventuelles failles de sécurités affectant vos logiciels ne seront plus corrigées.
Ligne 36: Ligne 38:
  
 ===== À partir de quelle version puis-je effectuer une mise à niveau vers la version la plus récente d'​Ubuntu ? ===== ===== À partir de quelle version puis-je effectuer une mise à niveau vers la version la plus récente d'​Ubuntu ? =====
-  * Pour mettre à niveau vers une version intermédiaire d'​Ubuntu,​ vous devez effectuer une mise à niveau à partir de la version stable directement précédente. Par exemple, une mise à niveau vers Ubuntu ​17.04 ne peut être effectuée qu'à partir de la précédente version stable ​16.10 ; +  * Pour mettre à niveau vers une version intermédiaire d'​Ubuntu,​ vous devez effectuer une mise à niveau à partir de la version stable directement précédente. Par exemple, une mise à niveau vers Ubuntu ​19.04 ne peut être effectuée qu'à partir de la précédente version stable ​18.10 ; 
-  * Pour mettre à niveau vers une version LTS d'​Ubuntu,​ vous devez effectuer une mise à niveau à partir de la version stable directement précédente ou de la version LTS directement précédente. Par exemple, une mise à niveau vers Ubuntu ​16.04 LTS ne peut être effectuée qu'à partir de la précédente version (15.10) ou de la précédente version LTS (14.04).+  * Pour mettre à niveau vers une version LTS d'​Ubuntu,​ vous devez effectuer une mise à niveau à partir de la version stable directement précédente ou de la version LTS directement précédente. Par exemple, une mise à niveau vers Ubuntu ​20.04 LTS ne peut être effectuée qu'à partir de la précédente version (19.10) ou de la précédente version LTS (18.04).
  
 Pour connaître la version actuelle de votre système, consultez [[:​versions#​connaitre_sa_version|la rubrique d'​aide]]. Pour connaître la version actuelle de votre système, consultez [[:​versions#​connaitre_sa_version|la rubrique d'​aide]].
Ligne 69: Ligne 71:
 Fermez le plus possible d'​application et lancez le [[:​gestionnaire_de_mises_a_jour|gestionnaire de mise à jour]] (update manager) depuis la liste des programmes. Cet utilitaire sert avant tout à mettre à jour votre système, mais il permet aussi d'​effectuer les mises à niveau. Pour cela, il faut d'​abord mettre à jour le système pour pouvoir mettre à niveau. Cliquez sur vérifier (Check) pour qu'il cherche les éventuelles mises à jour. Si votre système est à jour, il vous proposera déjà de mettre à niveau. Sinon, procédez à la mise à jour du système. Une fois la mise à jour effectuée, le gestionnaire de mise à jour doit vous proposer de mettre à niveau. Vous pouvez lancer la mise à niveau. Fermez le plus possible d'​application et lancez le [[:​gestionnaire_de_mises_a_jour|gestionnaire de mise à jour]] (update manager) depuis la liste des programmes. Cet utilitaire sert avant tout à mettre à jour votre système, mais il permet aussi d'​effectuer les mises à niveau. Pour cela, il faut d'​abord mettre à jour le système pour pouvoir mettre à niveau. Cliquez sur vérifier (Check) pour qu'il cherche les éventuelles mises à jour. Si votre système est à jour, il vous proposera déjà de mettre à niveau. Sinon, procédez à la mise à jour du système. Une fois la mise à jour effectuée, le gestionnaire de mise à jour doit vous proposer de mettre à niveau. Vous pouvez lancer la mise à niveau.
  
-<note warning>​D'​une version à une autre, l'​environnement graphique peut changer. Ainsi, ​les mises à niveau depuis un environnement graphique est toujours plus dangereux qu'​une ​mise à niveau en mode console ​décrit ​plus bas.</​note>​+<note warning>​D'​une version à une autre, l'​environnement graphique peut changer. Ainsi, ​une mise à niveau depuis un environnement graphique est toujours plus dangereuse que la mise à niveau en mode console ​décrite ​plus bas.</​note>​
  
 ===== Les serveurs principaux sont surchargés. Existe-t-il des serveurs miroirs depuis lesquels je pourrais effectuer une mise à niveau ? ===== ===== Les serveurs principaux sont surchargés. Existe-t-il des serveurs miroirs depuis lesquels je pourrais effectuer une mise à niveau ? =====
Ligne 82: Ligne 84:
 Pendant la mise à niveau de nombreux incidents peuvent survenir : une coupure de courant, plus d'​accès au serveur de mise à jour ou encore le petit dernier qui débranche la prise électrique. On peut ainsi se retrouver avec une mise à niveau incomplète ou des dépendances non satisfaites. Pendant la mise à niveau de nombreux incidents peuvent survenir : une coupure de courant, plus d'​accès au serveur de mise à jour ou encore le petit dernier qui débranche la prise électrique. On peut ainsi se retrouver avec une mise à niveau incomplète ou des dépendances non satisfaites.
  
-En cas de problème mineur de dépendances,​ tentez les commandes:​ +En cas de problème mineur de dépendances, ​[[recovery_mode|booter]] avec un ancien noyau  puis tentez les commandes:​ 
-  sudo dpkg --configure -a +<code bash>sudo dpkg --configure -a</​code>​ 
-puis: +puis  
-  sudo apt-get -f install+<code bash>sudo apt-get -f install</​code>​ 
 + 
 +FIXME la commande qui suit semble ne plus prendre en compte ​ le -a à vérifier. 
 +Si votre mise à niveau ne s'est pas terminée ou qu'un souci majeur est intervenu, vous pouvez tenter la commande : 
 +<code bash>​sudo dpkg-reconfigure -phigh -a</​code>​
  
-Si votre mise à niveau ne s'est pas terminée ou qu'un soucis majeur est intervenu, vous pouvez tenter la commande: 
-<​code>​sudo dpkg-reconfigure -phigh -a</​code>​ 
  
  
 Cette commande aura pour effet de réinstaller et reconfigurer les paquets de la mise à niveau. Cette commande aura pour effet de réinstaller et reconfigurer les paquets de la mise à niveau.
 Notez qu'​elle peut durer un certain temps, parfois une heure. Notez qu'​elle peut durer un certain temps, parfois une heure.
 +<code bash>​sudo dpkg-reconfigure -phigh -a 
 +Unknown option: a
 +Utilisation :​ dpkg-reconfigure [options] paquets
 +  -u,  --unseen-only affiche seulement les questions qui n'ont
 +                    pas encore été posées ;
 +       ​--default-priority utilise la priorité par défaut plutôt
 +                          que la priorité basse ;
 +       ​--force force la reconfiguration des paquets cassés.
 +       ​--no-reload ne pas recharger les modèles. (à utiliser
 +                          avec précaution)
 +  -f,  --frontend indique l'​interface debconf à utiliser ;
 +  -p,  --priority indique la priorité minimale à afficher ;
 +       ​--terse active le mode laconique (« terse »).
 +
 +</​code>​
  
-[[http://​www.clapico.com/​2009/​12/​02/​reinstallez-ubuntu/​|Source]] 
-<​note>​L’option -a n’existe plus pour dpkg-reconfigure sous Ubuntu 15.04. Cette dernière commande n’est donc plus possible.</​note>​ 
 ===== Guides spécifiques de mise à niveau ===== ===== Guides spécifiques de mise à niveau =====
- 
- 
- 
-==== Versions soutenues ==== 
- 
-=== vers 16.04 === 
- 
-Possible depuis 15.10 ou depuis 14.04. ​ 
- 
-=== vers 14.04 === 
- 
-Possible depuis 13.10 ou depuis 12.04. ​ 
- 
-. 
- 
- 
- 
- 
- 
  
 ==== Versions non soutenues (obsolètes,​ fin de vie) ==== ==== Versions non soutenues (obsolètes,​ fin de vie) ====
 La migration vers une [[:​old-releases|version obsolète d'​Ubuntu]] n'est pas possible. [[:​tutoriel:​sauvegarder_home|Sauvegarder vos données]] et installer une [[:​versions|version]] encore soutenue est la seule procédure recommandée.\\ La migration vers une [[:​old-releases|version obsolète d'​Ubuntu]] n'est pas possible. [[:​tutoriel:​sauvegarder_home|Sauvegarder vos données]] et installer une [[:​versions|version]] encore soutenue est la seule procédure recommandée.\\
-Les [[:​dépôts]] des vieilles versions n'​étant plus supportées (comme ​14.10, 15.04 et 15.10) ont été déplacées vers un serveur d'​archive. Aussi, il faudra modifier la liste des dépôts: Voir cette [[:​old-releases|page]].+Les [[:​dépôts]] des vieilles versions n'​étant plus supportées (comme ​17.10, 18.10 et 19.04) ont été déplacées vers un serveur d'​archive. Aussi, il faudra modifier la liste des dépôts: Voir cette [[:​old-releases|page]].
  
-===== Migration en ligne de commande ​(plutôt destinée aux serveurs ou aux utilisateurs avancés)=====+===== Migration en ligne de commande =====
  
 L'​outil en ligne de commande **do-release-upgrade** permet d'​effectuer une mise à niveau d'​Ubuntu sans utiliser d'​utilitaire graphique. Il est particulièrement pertinent pour les serveurs, qui fonctionnent sans interface graphique. L'​ensemble des options de cet outil peut être lue en exécutant la commande : L'​outil en ligne de commande **do-release-upgrade** permet d'​effectuer une mise à niveau d'​Ubuntu sans utiliser d'​utilitaire graphique. Il est particulièrement pertinent pour les serveurs, qui fonctionnent sans interface graphique. L'​ensemble des options de cet outil peut être lue en exécutant la commande :
Ligne 128: Ligne 126:
 Voici quelques-unes des options les plus utiles : Voici quelques-unes des options les plus utiles :
  
-  * <​code>​do-release-upgrade --check-dist-upgrade-only</​code>​L'​option ''​--check-dist-upgrade-only''​ vérifie l'​existence d'une nouvelle version. Si une nouvelle version est trouvée, celle-ci est affichée en résultat dans le terminal. Exécutée ainsi, cette commande n'​effectue qu'une vérification ; aucune mise à niveau n'est faite. +  * <​code>​do-release-upgrade --check-dist-upgrade-only</​code>​L'​option ''​%%--check-dist-upgrade-only%%''​ vérifie l'​existence d'une nouvelle version. Si une nouvelle version est trouvée, celle-ci est affichée en résultat dans le terminal. Exécutée ainsi, cette commande n'​effectue qu'une vérification ; aucune mise à niveau n'est faite. 
-  * <​code>​do-release-upgrade --sandbox</​code>​L'​option ''​--sandbox''​ permet de tester une mise à niveau dans un environnement protégé. Ceci est particulièrement utile pour tester le déploiement d'une mise à niveau avant de procéder à son application dans l'​environnement de production. +  * <​code>​do-release-upgrade --sandbox</​code>​L'​option ''​%%--sandbox%%''​ permet de tester une mise à niveau dans un environnement protégé. Ceci est particulièrement utile pour tester le déploiement d'une mise à niveau avant de procéder à son application dans l'​environnement de production. 
-  * <​code>​do-release-upgrade</​code>​ + 
-          ​mise ​à niveau sans interaction + 
-  *  ​<​code>​do-release-upgrade -f DistUpgradeViewNonInteractive</​code>​+ 
 +  * <​code>​do-release-upgrade</​code>​ ou avec une interface graphique : <code bash>​sudo do-release-upgrade -f DistUpgradeViewGtk3</​code>​ 
 +  * Mise à niveau sans interaction ​<​code>​do-release-upgrade -f DistUpgradeViewNonInteractive</​code>​
 Sans option, l'​outil ''​do-release-upgrade''​ recherche et procède à une mise à niveau vers la prochaine version LTS ou stable disponible, si elle existe. Sans option, l'​outil ''​do-release-upgrade''​ recherche et procède à une mise à niveau vers la prochaine version LTS ou stable disponible, si elle existe.
  
 <note tip>​**Mise à niveau vers une version de développement** \\ Les options suivantes permettent de vérifier l'​existence d'une nouvelle version de développement et de procéder à la mise à niveau vers celle-ci. Elles ne devraient être utilisées que dans des environnements de développement,​ puisqu'​elles peuvent être instables et contenir des bogues. <note tip>​**Mise à niveau vers une version de développement** \\ Les options suivantes permettent de vérifier l'​existence d'une nouvelle version de développement et de procéder à la mise à niveau vers celle-ci. Elles ne devraient être utilisées que dans des environnements de développement,​ puisqu'​elles peuvent être instables et contenir des bogues.
-  * <​code>​do-release-upgrade --check-dist-upgrade-only --devel-release</​code>​Le couple d'​options ''​--check-dist-upgrade-only''​ et ''​--devel-release''​ vérifie l'​existence d'une nouvelle version de développement. Si une nouvelle version de développement est trouvée, celle-ci est affichée en résultat dans le terminal. Exécutée ainsi, cette commande n'​effectue qu'une vérification ; aucune mise à niveau n'est faite. +  * <​code>​do-release-upgrade --check-dist-upgrade-only --devel-release</​code>​Le couple d'​options ''​%%--check-dist-upgrade-only%%''​ et ''​%%--devel-release%%''​ vérifie l'​existence d'une nouvelle version de développement. Si une nouvelle version de développement est trouvée, celle-ci est affichée en résultat dans le terminal. Exécutée ainsi, cette commande n'​effectue qu'une vérification ; aucune mise à niveau n'est faite. 
-  * <​code>​do-release-upgrade --devel-release</​code>​L'​option ''​--devel-release''​ recherche et procède à une mise à niveau vers la prochaine version de développement disponible, si elle existe.+  * <​code>​do-release-upgrade --devel-release</​code>​L'​option ''​%%--devel-release%%''​ recherche et procède à une mise à niveau vers la prochaine version de développement disponible, si elle existe.
 </​note>​ </​note>​
  
Ligne 154: Ligne 154:
 </​code>​ </​code>​
 C'est normal ! Il faudra attendre la version LTS+1.1 (14.04.1 par exemple) qui est la première grosse mise à jours corrective et qui est généralement annoncée 3 mois après la sortie de la LTS. \\ C'est normal ! Il faudra attendre la version LTS+1.1 (14.04.1 par exemple) qui est la première grosse mise à jours corrective et qui est généralement annoncée 3 mois après la sortie de la LTS. \\
-Si vous avez vraiment besoin ​d'​upgrader ​vers la nouvelle LTS, vous pouvez utiliser (à vos risques et périls) l'​option ''​-d''​ (''​%%--%%devel-release''​) signifiant une migration vers la prochaine version en développement) à condition d'​être déjà sur une LTS et d'​avoir choisi ''​Prompt=lts''​.\\+Si vous avez vraiment besoin ​de mettre à niveau ​vers la nouvelle LTS, vous pouvez utiliser (à vos risques et périls) l'​option ''​-d''​ (''​%%--%%devel-release''​) signifiant une migration vers la prochaine version en développement) à condition d'​être déjà sur une LTS et d'​avoir choisi ''​Prompt=lts''​.\\
 N'​hésitez pas à utiliser l'​option ''​-c''​ (''​%%--%%check-dist-upgrade-only''​) en conjonction de ''​-d''​ pour vérifier que vous allez bien migrer vers la version voulue. N'​hésitez pas à utiliser l'​option ''​-c''​ (''​%%--%%check-dist-upgrade-only''​) en conjonction de ''​-d''​ pour vérifier que vous allez bien migrer vers la version voulue.
 ==== Migration en ligne de commande via SSH ==== ==== Migration en ligne de commande via SSH ====
  • migration.1513159230.txt.gz
  • Dernière modification: Le 13/12/2017, 11:00
  • par 193.55.175.20