Ceci est une ancienne révision du document !



Sortie de son via HDMI

Il peut arriver que pour certaines personnes, le branchement d'une sortie HDMI (télévision, moniteur supplémentaire, …) entraîne bien la diffusion de l'image mais pas celle du son, ce qui s'avère très rapidement handicapant. Cette page devrait vous aider à résoudre le problème.

Testé sous Ubuntu 10.10 utilisant le greffon Alsa.

  • Disposer d'une connexion à Internet configurée et activée.
  • Avoir mis à jour votre version d'Ubuntu
  • Avoir installé les pilotes pour ceux qui possèdent des carte graphiques NVidia ou ATI. L'installation de ces pilotes est requise pour avoir une maîtrise optimale de votre carte graphique par laquelle passera le son de la carte audio pour arriver à la sortie HDMI. Les utilisateurs de cartes Intel peuvent se diriger vers la page de documentation Intel Graphics
  • Avoir installé les paquets asoundconf-gtk, gnome-alsamixer et alsa-utils.

Dans un terminal, faites la commande suivante, puis appuyez sur la touche « Entrée » pour confirmer (votre mot de passe est requis) :

sudo apt-get install libasound2-plugins "pulseaudio-*" padevchooser paman pavucontrol paprefs pavumeter

1. Tout d'abord, choisissons la bonne carte son dans le Sélecteur de systèmes multimédia. Ouvrez un terminal ou faites Alt+F2, puis saisissez la commande suivante :

gstreamer-properties

Puis, sous l'onglet Audio, sélectionnez le greffon ALSA-Advanced Linux Sound Architecture pour la sortie et l'entrée par défaut.

Ensuite sélectionnez le bon périphérique de sortie "HDMI" et testez le pipeline pour vérifier que le son soit bien opérationnel (FIXME et pour ceux dont le pipeline ne donne rien ? :/). Sélectionnez le bon périphérique d'entrée si vous disposez d'une webcam. Puis fermez.

2. Ensuite entrez

gnome-alsamixer

Et vérifiez que le son n'est pas sur "muet". Activez bien tout les sons de sortie.

3. Allez dans le terminal et ouvrez :

gnome-volume-control

Ensuite assurez vous d'avoir bien choisi le bon périphérique d'entrée et sortie. Puis redémarrez et le son fonctionnera.

En cas de souci, essayez la commande
sudo alsa force-reload

FIXME

Voici les commandes les plus demandées pour que l'on vous aide en cas de soucis sur le forum.

commandedescription
alsamixer
Sert à avoir une interface de gestion du système de son dans le terminal pour régler les cartes son trouvées.
aplay -l
Sert à montrer les noms des cartes son reconnues et leurs numéros de périphériques et sous périphériques, ainsi que le nombre total de périphériques connectés.
cat /proc/asound/cards
Sert aussi à montrer ses cartes son mais sans les sous-périphériques.
lsmod | grep snd
Sert à voir si le son du périphérique sélectionné marche correctement.
sudo alsa force-reload
Sert à forcer alsa à redémarrer pour charger les périphériques et les nouveaux réglages.
gstreamer-properties
Sert à ouvrir une interface graphique pour paramétrer et tester les sorties/entrées audio et vidéo. Vous pourrez également choisir ici le greffon que vous voulez utiliser, pour le cas présent ce sera alsa architecture.
sudo dpkg-reconfigure linux-sound-base
sert à choisir le greffon à utiliser. Pour le cas présent ce sera alsa.
lspci | grep -i audio
Sert à détailler vos deux cartes son, leur ordre, et numéro "ICH"
lspci
Sert à voir tout le matériel connecté à l'ordinateur et leur chemin.
pavucontrol
Sert à démarrer un gestionnaire de son pulse audio pour activer les périphériques ou les désactiver par interface graphique. Très utile.
gnome-alsamixer
Ceci est une interface graphique très proche de l'interface par commande de "alsamixer".
asoundconf-gtk
Permet de sélectionner la carte son voulue.
gnome-volume-control
Permet de modifier le volume des événements sonores ainsi que de choisir le bon périphérique.

Le son peut être reconnu mais pas redirigé vers le bon périphérique de sortie de la carte NVidia

Pour trouver le bon périphérique, voici quelques pistes ( à suivre avec l'écran / la TV branché en HDMI, et l'affichage basculé avec twinview le cas échéant)

Dans ce cas ouvrez un terminal et tapez cette commande :

aplay -D plughw:2,9 /usr/share/sounds/alsa/Front_Center.wav

Si cette commande vous retourne une erreur de type :

aplay: main:654: Erreur d'ouverture audio: Aucun fichier ou dossier de ce type

changez dans la commande en question les chiffres 2,9 par ceux correspondant à votre périphérique digital, pour l'identifier vous pouvez vous aider de la liste des périphériques contenus dans /proc/asound/devices (consultez cette liste mais ne la modifiez surtout pas !). Dans un terminal, tapez

gedit /proc/asound/devices

vous y trouverez tous vos périphériques son, identifié comme suit 0- 1, 0 -4,… 2- 9, 2- 8, etc testez en remplaçant le 2,9 de l'exemple par les numéros que vous trouverez dans /proc/asound/devices

Une fois trouvé le bon périphérique, on va forcer pulseaudio à créer une entrée pour rediriger le son vers ce périphérique. Modifiez le fichier /etc/pulse/default.pa et à la fin du fichier rajoutez la ligne :

load-module module-alsa-sink device=hw:2,9

remplacez hw:2,9 par les n° correspondants à votre périphérique tel que déterminé plus haut. Après un redémarrage, allez dans le panneau de contrôle de son situé en haut a droite de votre écran et sélectionnez comme sortie "NVidia stéréo"

en Image ;)

Merci de signaler que vous aussi avez ce soucis au rapport de bug suivant : Rapport de bug Alsa

Merci à Exzemat pour ce rapport de bug corrigé.

FIXME Sources, infos complémentaires, sujets de forum…


Contributeur principal : Spelth.

  • son_via_le_port_hdmi.1323958656.txt.gz
  • Dernière modification: Le 11/07/2012, 21:43
  • (modification externe)