Contenu | Rechercher | Menus

Trucs et astuces pour utiliser Libreoffice

Cette page rassemble quelques astuces, procédures, souvent basiques, mais qui pourraient vous faire perdre du temps à les chercher par vous-même. N'hésitez pas ajouter les vôtres, si vous estimez qu'elles peuvent être fréquemment utilisées.

Compatibilité avec Microsoft Office

Si vous souhaitez travailler sur des documents provenant de (ou à destination de) la suite bureautique Microsoft Office, consultez le tutoriel Comment améliorer la compatibilité entre Libreoffice et MS Office.

Affichage en mode ruban comme pour MSOffice

À partir de la version 5.3 il est possible de modifier l’affichage de LibreOffice pour qu'il ressemble au mode ruban de MSOffice. Pour cela allez dans Outils →Option →Avancé et cochez la case Activer les fonctions expérimentales.
Après allez dans Affichage →Disposition barre d'outils →Métabarre.

Numéroter ses pages

Méthode simple et officielle

  • Allez dans Insertion → Pied de page → Tout ou Standard.
  • Cliquez sur le petit encadré Pied de page.
  • Allez dans Insertion → Champ → Numéro de page.
  • Vous pouvez placer ces numérotations ou vous le voudrez, elles se feront automatiquement sur chaque pages.

Numéroter à partir de la 2e page

Les solutions pour avoir une première page sans numérotation :

Solution manuelle :

  • Sur la première page :
    • Aller dans Format → Style et formatage → onglet Style de page → Première page
  • Sur la deuxième page :
    • Allez dans Insertion → Pied de page → Standard
    • Cliquez sur le petit encadré pied de page
    • Allez dans Insertion → Champ → Numéro de page
    • Double-cliquer sur le numéro de page que vous venez d'insérer, puis mettre -1 dans Correction.

Utiliser sa tablette graphique

Si vous disposez d'une tablette graphique, vous pouvez l'utiliser pour écrire dans un document, par exemple pour y apposer votre signature. Il suffit pour cela de cliquer sur l'icône « Afficher les fonctions de dessin » dans la barre supérieure, ou de passer par le menu Affichage > Barres d'outils > Dessin, puis de sélectionner dans la barre qui apparaît l'outil « ligne à main levée ». Chaque trait que vous ferez avec le stylet sera une nouvelle image vectorielle.

Récupérer ses palettes de couleurs ou de dégradés ou en utiliser d'autres

Dans Libreoffice 5 il est possible d'ajouter ses propres palettes de couleurs ou de dégradés personnalisés dans ~/.config/libreoffice/4/user/config. Ces palettes et dégradés seront ainsi disponibles pour tous vos documents.

  • Les palettes de dégradés portent l'extension sog ( fichier.sog ).
  • Les palettes de couleurs portent l'extension soc ( fichier.soc ).

Pour connaître ou modifier une palette livrée avec l'installation de Libreoffice qui se trouve dans /usr/lib/libreoffice/share/palette, utilisez un éditeur de texte. Faites vos modifications et enregistrez votre palette dans ~/.config/libreoffice/4/user/config en utilisant un nom différent.

Une explication plus détaillée ici : http://dutailly.net/creer-une-palette-de-couleurs-pour-libreoffice

Se connecter à des bases de données

Pour effectuer un publipostage ou mailing, le paquet libreoffice-base doit être installé, faute de quoi les boutons "définir" restent grisés quand on tente de se connecter à un fichier de base de donnée

Il existe également des extensions pour augmenter la connectivité de LibreOffice.

Pour ce connecter à une base mysql ou autre voir la page décrivant la méthode, et pour une base access cette page.

Synthèse vocale

Reportez-vous à la page dédiée.

Autres astuces

Une présentation destinée à montrer l'utilisation de quelques fonctions pratiques de LibreOffice ("bons usages") est disponible sur https://perso.limsi.fr/pointal/divers:preslibreoffice


Contributeurs principaux : OStaquet, Adam0509, Id2ndR, Ner0lph, poupoul2, Psychederic.



Le contenu de ce wiki est sous licence : CC BY-SA v3.0